summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 06:49:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 07:14:53 +0200
commit3ad1d510e943671111ed769c247f1d3fad9b3bc4 (patch)
tree6b47b611d19f3bb9737ad73c8a51e7211ae6b885 /dev-python/jupyter_client
parentdev-python/pyjwt: Bump to 2.6.0 (diff)
downloadgentoo-3ad1d510e943671111ed769c247f1d3fad9b3bc4.tar.gz
gentoo-3ad1d510e943671111ed769c247f1d3fad9b3bc4.tar.bz2
gentoo-3ad1d510e943671111ed769c247f1d3fad9b3bc4.zip
dev-python/jupyter_client: Bump to 7.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.4.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index 76c19e50e4ef..834c22e5e093 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,2 +1,3 @@
DIST jupyter_client-7.3.5.tar.gz 326758 BLAKE2B c2ac76eb6511b29c38d7e7441e1191bae1f931da27f2eb95d6cb842a0e36f36a6f7a1421253b62abf52243f9fdad36b34828e6d5cd13a0411fa4ce09b447c3bc SHA512 5a3471fe03f44671fc2a06f8c78c11197084c8c951a1f8b55b89d651a6aea2ae1bdbb451ed463e52519954e7dba99b4e2298a6511eef2a3618f095dc864758d9
DIST jupyter_client-7.4.2.tar.gz 327079 BLAKE2B 71e1f2d7a84a308b37105887ab7851e1f8a8e1f3019d937ec2c48493396dd757f3b7bcd75be180187f2a2855f20f5c0db924b058d316a34d503a2964c63b65c9 SHA512 4e22cb0dccdc96d16c560dba2f9b19616015143d5bd709b9dafed9fa2419ab3d8e6f9091f8a94ab78a0a1d16db2db86def23300b6a39485c0c978f145da4eb47
+DIST jupyter_client-7.4.3.tar.gz 327186 BLAKE2B 04b601d0b492879b2a5f06c53610a354c640376707188fb75394df42ee4ea426ff87a9df5537e242115ea86a9db64bb625b0911407bfe5b00d667843cd78118a SHA512 620ebd31518b6161a32503c1fbb1f18c11e50c15bafd6a46747cc5de682d025aad626fae226ddcf9f2843fa9eb3580825c08474f7309906738da7a02c8d75193
diff --git a/dev-python/jupyter_client/jupyter_client-7.4.3.ebuild b/dev-python/jupyter_client/jupyter_client-7.4.3.ebuild
new file mode 100644
index 000000000000..58a093cf850d
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.4.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.12[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
+)
+
+distutils_enable_tests pytest