summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-14 08:04:57 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-14 08:26:35 +0100
commit1ee9bd4764537f0ae0d59c254356d63176258329 (patch)
tree7488d603b565b87e7fcd154d08227d4854937c10 /dev-python/jwcrypto
parentdev-python/pyrate-limiter: Bump to 3.2.1 (diff)
downloadgentoo-1ee9bd4764537f0ae0d59c254356d63176258329.tar.gz
gentoo-1ee9bd4764537f0ae0d59c254356d63176258329.tar.bz2
gentoo-1ee9bd4764537f0ae0d59c254356d63176258329.zip
dev-python/jwcrypto: Bump to 1.5.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jwcrypto')
-rw-r--r--dev-python/jwcrypto/Manifest1
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.5.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index fd2731ced7db..697ee5fc0b07 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1,2 +1,3 @@
DIST jwcrypto-1.5.1.gh.tar.gz 96563 BLAKE2B 13b39b27825031d4f30e1399bac085ba846551b5e50c49ae2a1ff31182e47a896ef9bfdd1705a40e59ddeb6850ba7bafd19ccf83d9f8177c47936e220df881db SHA512 fecb993a1157b6e689d3e845c8839f3178e32ab7fc920bf6b7328705293dae5e3d1424532b066f6dedd9c25a5cdeec91089ed4b83c4592cf6e1690419b5a5539
DIST jwcrypto-1.5.3.gh.tar.gz 96597 BLAKE2B 6efffce256f7652ca79316c0a4148df61bec65d74f275ffad6f665cfb26c14137ecc7ec219fa30c0f8dcdc3de8468a94dc158ed0b1f973b8d5a451fa1081fcae SHA512 90081959ebd3ff0d003e8bfb6f25e51243c6f7d522d085f5fa63e2a810707b070069a387fbf067c16e8bf3d8e84f9387c399a49a23e20c4d2007ab53e99f041d
+DIST jwcrypto-1.5.4.gh.tar.gz 96607 BLAKE2B a1558c58c26e6ecb3747c6e7d554bd2100fd8f3c9c5804cf2a596c55920399e879dad267bcbc162aab0b956bde129cdb0090af98171eb7cb06970ed0964f47d9 SHA512 085adfd5f894ee8215c70371d2ebc2e97a38efb17be14ee8433858474df906ff963f243f669e209624e7ec78c1eb8b5ccc2077f0fc50b4e5eef25885e338b4e1
diff --git a/dev-python/jwcrypto/jwcrypto-1.5.4.ebuild b/dev-python/jwcrypto/jwcrypto-1.5.4.ebuild
new file mode 100644
index 000000000000..aa90a1f6e229
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-1.5.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+HOMEPAGE="
+ https://github.com/latchset/jwcrypto/
+ https://pypi.org/project/jwcrypto/
+"
+SRC_URI="
+ https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-3.4[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -e "/data_files/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}