summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-27 08:35:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-27 09:39:34 +0200
commit8b4c2497ae8f4b74eb00a51f4e5485741614cf5d (patch)
treea58b5ced5ffabf4ee4d18b75372c05a55fddeadd /dev-python/keystoneauth1
parentdev-python/rich: Bump to 13.8.0 (diff)
downloadgentoo-8b4c2497ae8f4b74eb00a51f4e5485741614cf5d.tar.gz
gentoo-8b4c2497ae8f4b74eb00a51f4e5485741614cf5d.tar.bz2
gentoo-8b4c2497ae8f4b74eb00a51f4e5485741614cf5d.zip
dev-python/keystoneauth1: Bump to 5.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keystoneauth1')
-rw-r--r--dev-python/keystoneauth1/Manifest1
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.8.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/keystoneauth1/Manifest b/dev-python/keystoneauth1/Manifest
index e4af4b8d6fd5..ee31b50c0045 100644
--- a/dev-python/keystoneauth1/Manifest
+++ b/dev-python/keystoneauth1/Manifest
@@ -1 +1,2 @@
DIST keystoneauth1-5.7.0.tar.gz 275942 BLAKE2B 71e94ed879cb79b65ea19cb06718c10268979a4f271e04314b24db648eccf3b0003826e71942854360d3df7563c893ee73590a826337fe1c0aafb67245f58f2e SHA512 529a831b6ec51e780fae09d6368d32eabfc843d019a16101c66a6cf2b8ed6b246e1d9e8def5ed11154115b460e806f29a47cb419e1c72da43b7348480843255b
+DIST keystoneauth1-5.8.0.tar.gz 278617 BLAKE2B 93437140316d1f353c42f3e8face97d9510c4a795f5c5c7c29b7dbd7c66887a819d71a66f35ebbda3851174cc9c738f53d8edc35a940e4c06a0b4cec19db36d8 SHA512 a427c9a6339cce57e53b78ee3e33276a87753e4cee44fe5dfbc85c7d54bc95bbc1e4536a26c8d1be1ef5a392e9095d529fd64df0ce61f1a4a4c0ba8078b2cddd
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.8.0.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.8.0.ebuild
new file mode 100644
index 000000000000..825474f59123
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.8.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile to test runner name
+ keystoneauth1/tests/unit/test_session.py::SessionTests::test_user_agent
+ # broken betamax
+ keystoneauth1/tests/unit/test_betamax_fixture.py::TestBetamaxFixture::test_keystoneauth_betamax_fixture
+)
+
+EPYTEST_IGNORE=(
+ # require hacking
+ keystoneauth1/tests/unit/test_hacking_checks.py
+)