summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-01 04:18:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-01 05:17:04 +0200
commit24eda65d32055807b278aea8dffbe8b3064df7fa (patch)
treed8c0ce7cfcd9e306db383843588419fdc53d7b06 /dev-python/llfuse
parentdev-python/yarl: Bump to 1.9.6 (diff)
downloadgentoo-24eda65d32055807b278aea8dffbe8b3064df7fa.tar.gz
gentoo-24eda65d32055807b278aea8dffbe8b3064df7fa.tar.bz2
gentoo-24eda65d32055807b278aea8dffbe8b3064df7fa.zip
dev-python/llfuse: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.5.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index 90ce40f8ed31..3a04228425db 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1 +1,2 @@
DIST llfuse-1.5.0.tar.gz 869259 BLAKE2B 2a3eee64718f4a73b8dd51ccaeedd7b1b700f734b10daa864d2ca04da5f38ed6a514c4ae8b541000c4d4a3042dcd95533ff7c1df655d7b57ec89120a97d8a9b6 SHA512 bb84c697658e7cd39eb6af3a4a6085c3bc3295e5f0b4f35adf6565ecff5077acb27ecd92f7c6420aa06dab36d9b54915bce65e4ec3d011047a0a15cdccbbb284
+DIST llfuse-1.5.1.tar.gz 959557 BLAKE2B 0484c1b71b1293f4577039ff150bbf870350e25c091363affa99ca4c33dc4db72d7ff48747076707ca2de605c0ae15adaa49cfbcef3a52630e92b9f5bc717743 SHA512 c4dc25bb3cfe9abd0d7f6885a73f1b3e21a834554206cc6fdf6ba3f7e03f5f4f6c1117161528f4ea2bb93013abbcba0c87ce7fef3368ac147e4d15fe1c5dd113
diff --git a/dev-python/llfuse/llfuse-1.5.1.ebuild b/dev-python/llfuse/llfuse-1.5.1.ebuild
new file mode 100644
index 000000000000..01254a43809b
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.5.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="
+ https://github.com/python-llfuse/python-llfuse/
+ https://pypi.org/project/llfuse/
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=sys-fs/fuse-2.8.0:0
+"
+DEPEND="
+ ${RDEPEND}
+ sys-apps/attr
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/llfuse-1.3.5-cflags.patch
+)
+
+distutils_enable_sphinx rst
+distutils_enable_tests pytest
+
+src_prepare() {
+ # force regen
+ rm src/llfuse.c || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ if [[ ! -f src/llfuse.c ]]; then
+ esetup.py build_cython
+ fi
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}