summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-11 20:54:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-11 21:58:52 +0200
commit998495aed106e96640c9f5cfda3169a71ed56957 (patch)
tree02d6dc1339b58b843b1557498021c9ae9d000b1d /dev-python/manuel
parentdev-python/zope-testing: Use distutils_write_namespace (diff)
downloadgentoo-998495aed106e96640c9f5cfda3169a71ed56957.tar.gz
gentoo-998495aed106e96640c9f5cfda3169a71ed56957.tar.bz2
gentoo-998495aed106e96640c9f5cfda3169a71ed56957.zip
dev-python/manuel: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/manuel')
-rw-r--r--dev-python/manuel/manuel-1.10.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/manuel/manuel-1.10.1-r1.ebuild b/dev-python/manuel/manuel-1.10.1-r1.ebuild
new file mode 100644
index 000000000000..300f45e5df0c
--- /dev/null
+++ b/dev-python/manuel/manuel-1.10.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lets you mix and match traditional doctests with custom test syntax"
+HOMEPAGE="
+ https://github.com/benji-york/manuel/
+ https://pypi.org/project/manuel/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # unused rdep
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}