summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-18 06:48:48 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-18 08:02:57 +0100
commit3cadee5e774076960ba2fdfcca83c61b38d34249 (patch)
tree638b36110f2ceab692e36b22489962a6fb4187dd /dev-python/meson-python
parentdev-python/google-auth: Bump to 2.16.1 (diff)
downloadgentoo-3cadee5e774076960ba2fdfcca83c61b38d34249.tar.gz
gentoo-3cadee5e774076960ba2fdfcca83c61b38d34249.tar.bz2
gentoo-3cadee5e774076960ba2fdfcca83c61b38d34249.zip
dev-python/meson-python: Bump to 0.12.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest1
-rw-r--r--dev-python/meson-python/meson-python-0.12.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index bf2de6fcf360..7212b4adda2b 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1 +1,2 @@
DIST meson-python-0.12.0.gh.tar.gz 43801 BLAKE2B fa4f5b73d490fce64da5c9f79c590e32af5b39790c0ffddc694a6b11a9274760a4e92a3d45abdefdbec1e6c5235ae799ee6c3e1b99685028b3bc007d5322683d SHA512 f2e416027bb6fb6cf6ad0fd84c6b65ddc83b497ff96b5a144dfcdd1addee44972eaa7422c8d9a8092431b6df1b052f970e9e7bd7dc57b28fbf42d2ea3a8d9231
+DIST meson-python-0.12.1.gh.tar.gz 43855 BLAKE2B 96b9ff5ef628bb471f7f79ce30ec6f3f851ce0006327e8b3a6003fdcb768f3280c0ee882d1c0c8ea183b0f2319d7c977c3fbb62742e3127bafb73e9732b3a1a9 SHA512 6f8e840da0155f2dd0e7139387f875cfad79eb042abcfa69b3043f51cbae3222fc2986e13798389909a0b4719513c93af381ec00a69fdfedf14bbe4e100b2f08
diff --git a/dev-python/meson-python/meson-python-0.12.1.ebuild b/dev-python/meson-python/meson-python-0.12.1.ebuild
new file mode 100644
index 000000000000..07fb16ba0821
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.12.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/mesonbuild/meson-python/
+"
+SRC_URI="
+ https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.6.1[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.0-defaults.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+ )
+ unset NINJA
+
+ epytest
+
+ rm -rf docs/examples/spam/build/ || die # remove artifacts
+}