summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-23 09:14:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-23 09:30:40 +0200
commitb822cb644f596cf019c917a8ac2ef426cc999db0 (patch)
tree944d62595a6ad6aa41ba32f9f4388ddcc4e8b63e /dev-python/meson-python
parentapp-editors/vscode: add 1.74.2 (diff)
downloadgentoo-b822cb644f596cf019c917a8ac2ef426cc999db0.tar.gz
gentoo-b822cb644f596cf019c917a8ac2ef426cc999db0.tar.bz2
gentoo-b822cb644f596cf019c917a8ac2ef426cc999db0.zip
dev-python/meson-python: add 0.12.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest1
-rw-r--r--dev-python/meson-python/meson-python-0.12.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index 6bcfab8c89b7..bd8453343e32 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1 +1,2 @@
DIST meson-python-0.11.0.gh.tar.gz 43192 BLAKE2B c12a18698f270b36685bbd4ad7ff5f2a718bab28f834cad89be724457704cd56966247e13ed6ba7dd201c5397ccfc78ab9202e7435f0672d63d544f67323b7b3 SHA512 fb894d0db6d18febd6388b7e686d0c7c1e3308f6ebf926c7300e2f376b1d2a803adcf5925c80d05982805e3ce4a59676c9ef829eacdab4696dabec3cb93e4192
+DIST meson-python-0.12.0.gh.tar.gz 43801 BLAKE2B fa4f5b73d490fce64da5c9f79c590e32af5b39790c0ffddc694a6b11a9274760a4e92a3d45abdefdbec1e6c5235ae799ee6c3e1b99685028b3bc007d5322683d SHA512 f2e416027bb6fb6cf6ad0fd84c6b65ddc83b497ff96b5a144dfcdd1addee44972eaa7422c8d9a8092431b6df1b052f970e9e7bd7dc57b28fbf42d2ea3a8d9231
diff --git a/dev-python/meson-python/meson-python-0.12.0.ebuild b/dev-python/meson-python/meson-python-0.12.0.ebuild
new file mode 100644
index 000000000000..54415126ce33
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.12.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/mesonbuild/meson-python/
+"
+SRC_URI="
+ https://github.com/mesonbuild/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.6.1[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
+ dev-util/patchelf
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.0-defaults.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+)
+
+src_prepare() {
+ # strip dependency on ninja -- we provide ninja via Gentoo package
+ # rather than the Python wheel, so we don't have .dist-info there
+ sed -i -e '/ninja/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires network access
+ tests/test_pep518.py::test_pep518
+ )
+
+ epytest
+
+ rm -rf docs/examples/spam/build/ || die # remove artifacts
+}