summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-08-04 21:03:18 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-08-04 21:13:16 +0200
commit1f261bcca2042f97f567f3842e8ce0e18d8c203a (patch)
treeda36a64eb2d57004ea4dd1e0fc9d8beb485795fe /dev-python/mysql-connector-python
parentdev-db/mysql-connector-c++: bump to v8.0.26 (diff)
downloadgentoo-1f261bcca2042f97f567f3842e8ce0e18d8c203a.tar.gz
gentoo-1f261bcca2042f97f567f3842e8ce0e18d8c203a.tar.bz2
gentoo-1f261bcca2042f97f567f3842e8ce0e18d8c203a.zip
dev-python/mysql-connector-python: bump to v8.0.26
Package-Manager: Portage-3.0.21, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-python/mysql-connector-python')
-rw-r--r--dev-python/mysql-connector-python/Manifest1
-rw-r--r--dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/mysql-connector-python/Manifest b/dev-python/mysql-connector-python/Manifest
index 6e75b6a8a05e..145ae5916c4c 100644
--- a/dev-python/mysql-connector-python/Manifest
+++ b/dev-python/mysql-connector-python/Manifest
@@ -1,3 +1,4 @@
DIST mysql-connector-python-8.0.22.tar.gz 12081967 BLAKE2B fc6b724ec2eb47a92294f7316093d4a4d2f4925981adeb07b305e946a047dbdaedd96c6ff9a07426fd56185f467cf6473bc84e0896d2e8fde70a188af16e9df2 SHA512 07f380922c18f9ade38f95d8e107fe8f90b8a7901fb9a36bbdfdb2b29f9cb79b0b6387a608e89bf90e9344c635d47184c750a206beacb2c9cc7615d6a7df2c29
DIST mysql-connector-python-8.0.23.tar.gz 12095843 BLAKE2B e4cc24f045d0e988ad97a9427fa3f6e20eb9d993d97f51033140e12722bc04fc3a2b252b811402daea2fea8f987948ebd8c68623f2af3e0e7e35d2b0d6fa7eda SHA512 66ca61c15573555a3f42ad8a9e9b3a4bc612c4d2b4e54928af87adcf609e131e9afd53b76c3a8da30f181e4f2111245cda5995063109526ff72f4f2062c2e528
DIST mysql-connector-python-8.0.25.tar.gz 14600643 BLAKE2B e3452aa82dc047cfdec8e64975ceb4f1ba7804aae770956fa52293e185408a4a31b2f563a21dcc6f0c5be0f4a5858d6b58f0d33ab5cf5071543e2c68b2b52b52 SHA512 2a76b879b369e69e0ed6a67d1eab4787c0f9a29c505ad785b03b6b25d7c92b85547082adeae572c75e61b613f39ee01d291fdf54927bdaf25dfcfc85cb8ced7c
+DIST mysql-connector-python-8.0.26.tar.gz 15180658 BLAKE2B e964728d5f39b9ca5abc72ab84780b463708d1a1cf90507330e73be4837cd30befe245ddd70783490660c70da1b7c162803eee743a0e668cfa6b82773bea4fef SHA512 204021e08b21c5efe87c0f59a6ff3b949cc1d01005121dfe5dde7fea12852a3e28c35b68e06e04f2c0ac4f911bfc14893e6509c99d0c5bf2c30fa32d4131c630
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild
new file mode 100644
index 000000000000..454f690c682b
--- /dev/null
+++ b/dev-python/mysql-connector-python/mysql-connector-python-8.0.26.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client library for MariaDB/MySQL"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
+SRC_URI="https://github.com/mysql/mysql-connector-python/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+
+BDEPEND=">=dev-libs/protobuf-3.6.1"
+
+RDEPEND="
+ >=dev-db/mysql-connector-c-8.0
+ >=dev-python/protobuf-python-3.6.1[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+# tests/mysqld.py does not like MariaDB version strings.
+# See the regex MySQLServerBase._get_version.
+DEPEND="${RDEPEND} test? ( dev-db/mysql[server(+)] )"
+
+# Tests currently fail.
+# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
+RESTRICT="test"
+
+DOCS=( README.txt CHANGES.txt README.rst )
+
+python_test() {
+ "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
+}
+
+# Yeah, this is really broken, but the extension will only build this way during "install"
+python_install() {
+ distutils-r1_python_install \
+ --with-mysql-capi="${EPREFIX}/usr" \
+ --with-protobuf-include-dir="${EPREFIX}/usr/include/google/protobuf/" \
+ --with-protobuf-lib-dir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-protoc="${EPREFIX}/usr/bin/protoc"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples ; then
+ dodoc -r examples
+ fi
+}