summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/nautilus-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/nautilus-python')
-rw-r--r--dev-python/nautilus-python/Manifest1
-rw-r--r--dev-python/nautilus-python/metadata.xml8
-rw-r--r--dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild50
-rw-r--r--dev-python/nautilus-python/nautilus-python-1.1-r2.ebuild52
4 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/nautilus-python/Manifest b/dev-python/nautilus-python/Manifest
new file mode 100644
index 000000000000..712a077d0862
--- /dev/null
+++ b/dev-python/nautilus-python/Manifest
@@ -0,0 +1 @@
+DIST nautilus-python-1.1.tar.xz 239392 SHA256 7825e08ada8e131f829d0e7d4144dcfac9fad7bfd7c0600bf3985349c20c496b SHA512 e721f46414a3efa4b5f5ec3f56cc00a308ec010a7a0612cef975d6f436494701f8bdbed39bdb5186c8013a582c7e63288a1c60adc4b8967c9ec69d6301a50fef WHIRLPOOL 280b6019a9850596b69777a758d89b06bfce5f30188feb274c8d5820ec6b9ecfcc8c0c402dbfee184378b2c02b6c29bc798ff061a139defd8cfae4e12b5d591d
diff --git a/dev-python/nautilus-python/metadata.xml b/dev-python/nautilus-python/metadata.xml
new file mode 100644
index 000000000000..21ba9b5773cc
--- /dev/null
+++ b/dev-python/nautilus-python/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild b/dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild
new file mode 100644
index 000000000000..fd59a87fc1cc
--- /dev/null
+++ b/dev-python/nautilus-python/nautilus-python-1.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 python
+
+DESCRIPTION="Python bindings for the Nautilus file manager"
+HOMEPAGE="http://projects.gnome.org/nautilus-python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 x86"
+IUSE="doc"
+
+# Depend on pygobject:3 for sanity, and because it's automagic
+RDEPEND="dev-python/pygobject:3
+ >=gnome-base/nautilus-2.32[introspection]"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ gnome2_src_install
+ # Directory for systemwide extensions
+ keepdir /usr/share/nautilus-python/extensions/
+ # Doesn't get installed by "make install" for some reason
+ if use doc; then
+ insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ doins -r docs/html/*
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_need_rebuild
+}
diff --git a/dev-python/nautilus-python/nautilus-python-1.1-r2.ebuild b/dev-python/nautilus-python/nautilus-python-1.1-r2.ebuild
new file mode 100644
index 000000000000..d629054e7cb9
--- /dev/null
+++ b/dev-python/nautilus-python/nautilus-python-1.1-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="Python bindings for the Nautilus file manager"
+HOMEPAGE="http://projects.gnome.org/nautilus-python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Depend on pygobject:3 for sanity, and because it's automagic
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=gnome-base/nautilus-2.32[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-1.9 )
+"
+
+src_configure() {
+ # FIXME: package does not ship pre-built documentation
+ # and has broken logic for dealing with gtk-doc
+ gnome2_src_configure $(use_enable doc gtk-doc)
+}
+
+src_install() {
+ gnome2_src_install
+ # Directory for systemwide extensions
+ keepdir /usr/share/nautilus-python/extensions
+ # Doesn't get installed by "make install" for some reason
+ if use doc ; then
+ insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+ doins -r docs/html/.
+ fi
+}