summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2020-09-25 14:56:03 +0200
committerDaniel Pielmeier <billie@gentoo.org>2020-09-25 14:56:03 +0200
commit3d6a57aace91acaada1cf279edb1fa64efc70357 (patch)
tree4c77af35093a7b9ec38363f3b26f0129389a177e /dev-python/notify2
parentapp-portage/pfl: Add python 3.9 support. (diff)
downloadgentoo-3d6a57aace91acaada1cf279edb1fa64efc70357.tar.gz
gentoo-3d6a57aace91acaada1cf279edb1fa64efc70357.tar.bz2
gentoo-3d6a57aace91acaada1cf279edb1fa64efc70357.zip
dev-python/notify2: Add python 3.9 support.
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'dev-python/notify2')
-rw-r--r--dev-python/notify2/notify2-0.3.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/notify2/notify2-0.3.1-r2.ebuild b/dev-python/notify2/notify2-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..9343d56739df
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to DBus notifications."
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+BDEPEND="test? ( sys-apps/dbus[X] )"
+
+python_test() {
+ virtx ${EPYTHON} test_notify2.py
+}
+
+python_install_all() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+ distutils-r1_python_install_all
+}