summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-22 02:51:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-22 03:20:36 +0200
commit777e9637fee75a3196b82c7c6c45c6433de22241 (patch)
tree2bcac12fc57a7a9a6b6fd69817b5745e6c27cc81 /dev-python/numpy
parentdev-python/tifffile: Remove old (diff)
downloadgentoo-777e9637fee75a3196b82c7c6c45c6433de22241.tar.gz
gentoo-777e9637fee75a3196b82c7c6c45c6433de22241.tar.bz2
gentoo-777e9637fee75a3196b82c7c6c45c6433de22241.zip
dev-python/numpy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/Manifest1
-rw-r--r--dev-python/numpy/files/numpy-2.0.0_rc2-gcc14.patch23
-rw-r--r--dev-python/numpy/numpy-2.0.0_rc2-r1.ebuild127
3 files changed, 0 insertions, 151 deletions
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index 0e5f535e1a09..a03c8536ddc2 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -1,3 +1,2 @@
DIST numpy-1.26.4.tar.gz 15786129 BLAKE2B ee759d3a857111bc494d5e989a7b005375d942b2a89cda69be4a3bd7c6cb195003fd2a8a0535f1858d8977ff688b0ec36360dcba9c3160206eedce5e28f191ef SHA512 f7121ab4099fa0686f9c095d456baa4a5869d651d7b7a06385f885f329cf08f11024b5df5e7b4ee705970062a8102ec4f709512eabbfd5c9fccce4ef83b9c208
DIST numpy-2.0.0.tar.gz 18326228 BLAKE2B e3d1084b79e0e55cd9087bb34dc116e6c9d6ab14a416a07f727b9f5d5a9db236ecf74a53b7e758d078781c5e565e5557912962f2ddbfff7251ec5b231fabe01d SHA512 cd5612ce2db4be87afa8479c508c256c9ff7f1b15a6b010eb06ba962759cc26552b512ec82711680bab1ebedeb06dfc8d7bff9cec63c94efacaadd719448b287
-DIST numpy-2.0.0rc2.tar.gz 18323588 BLAKE2B e2d5d03594d0cba360d4e85207818d15a0761f37cc3fb366f8f9f8bdd97743fe0cf0d09a34319c8b6af29b2bc1fc32a7f5be30a5fa2bdebffe455baff05caf7e SHA512 f86b27264c5274823aa11cbedf17c08f81f9acd05430bf40cccbbe8dcff523410629795ca5927d7f8e6c152272b274d777b64f547d23f50d11ae9fd656fd773d
diff --git a/dev-python/numpy/files/numpy-2.0.0_rc2-gcc14.patch b/dev-python/numpy/files/numpy-2.0.0_rc2-gcc14.patch
deleted file mode 100644
index f3ed3727520d..000000000000
--- a/dev-python/numpy/files/numpy-2.0.0_rc2-gcc14.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From f3bc38235bf39a630035920e29f2f883cae5fffe Mon Sep 17 00:00:00 2001
-From: Matti Picus <matti.picus@gmail.com>
-Date: Sun, 26 May 2024 11:25:43 +0300
-Subject: [PATCH 1/3] BUG: cast missing in PyPy-specific f2py code
-
----
- numpy/f2py/cb_rules.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/numpy/f2py/cb_rules.py b/numpy/f2py/cb_rules.py
-index 721e075b6c73..faf8dd401301 100644
---- a/numpy/f2py/cb_rules.py
-+++ b/numpy/f2py/cb_rules.py
-@@ -122,7 +122,7 @@
- #setdims#
- #ifdef PYPY_VERSION
- #define CAPI_ARGLIST_SETITEM(idx, value) PyList_SetItem((PyObject *)capi_arglist_list, idx, value)
-- capi_arglist_list = PySequence_List(capi_arglist);
-+ capi_arglist_list = PySequence_List((PyObject *)capi_arglist);
- if (capi_arglist_list == NULL) goto capi_fail;
- #else
- #define CAPI_ARGLIST_SETITEM(idx, value) PyTuple_SetItem((PyObject *)capi_arglist, idx, value)
-
diff --git a/dev-python/numpy/numpy-2.0.0_rc2-r1.ebuild b/dev-python/numpy/numpy-2.0.0_rc2-r1.ebuild
deleted file mode 100644
index d33733489b22..000000000000
--- a/dev-python/numpy/numpy-2.0.0_rc2-r1.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-FORTRAN_NEEDED=lapack
-
-inherit distutils-r1 flag-o-matic fortran-2 pypi
-
-DESCRIPTION="Fast array and numerical python library"
-HOMEPAGE="
- https://numpy.org/
- https://github.com/numpy/numpy/
- https://pypi.org/project/numpy/
-"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-# +lapack because the internal fallbacks are pretty slow. Building without blas
-# is barely supported anyway, see bug #914358.
-IUSE="+lapack"
-
-RDEPEND="
- lapack? (
- >=virtual/cblas-3.8
- >=virtual/lapack-3.8
- )
-"
-BDEPEND="
- ${RDEPEND}
- >=dev-build/meson-1.1.0
- >=dev-python/cython-3.0.6[${PYTHON_USEDEP}]
- lapack? (
- virtual/pkgconfig
- )
- test? (
- $(python_gen_cond_dep '
- >=dev-python/cffi-1.14.0[${PYTHON_USEDEP}]
- ' 'python*')
- dev-python/charset-normalizer[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}]
- >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-python_prepare_all() {
- local PATCHES=(
- # https://github.com/numpy/numpy/pull/26534
- "${FILESDIR}/${P}-gcc14.patch"
- )
-
- # bug #922457
- filter-lto
- # https://github.com/numpy/numpy/issues/25004
- append-flags -fno-strict-aliasing
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- DISTUTILS_ARGS=(
- -Dallow-noblas=$(usex !lapack true false)
- -Dblas=$(usev lapack cblas)
- -Dlapack=$(usev lapack lapack)
- # TODO: cpu-* options
- )
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Very disk-and-memory-hungry
- lib/tests/test_io.py::TestSaveTxt::test_large_zip
- lib/tests/test_io.py::TestSavezLoad::test_closing_fid
- lib/tests/test_io.py::TestSavezLoad::test_closing_zipfile_after_load
-
- # Precision problems
- _core/tests/test_umath_accuracy.py::TestAccuracy::test_validate_transcendentals
-
- # Runs the whole test suite recursively, that's just crazy
- core/tests/test_mem_policy.py::test_new_policy
-
- typing/tests/test_typing.py
- # Uses huge amount of memory
- core/tests/test_mem_overlap.py
- 'core/tests/test_multiarray.py::TestDot::test_huge_vectordot[complex128]'
- )
-
- if use arm && [[ $(uname -m || echo "unknown") == "armv8l" ]] ; then
- # Degenerate case of arm32 chroot on arm64, bug #774108
- EPYTEST_DESELECT+=(
- core/tests/test_cpu_features.py::Test_ARM_Features::test_features
- )
- fi
-
- case ${EPYTHON} in
- python3.13)
- EPYTEST_DESELECT+=(
- _core/tests/test_nditer.py::test_iter_refcount
- _core/tests/test_limited_api.py::test_limited_api
- )
- ;;
- esac
-
- if ! has_version -b "~${CATEGORY}/${P}[${PYTHON_USEDEP}]" ; then
- # depends on importing numpy.random from system namespace
- EPYTEST_DESELECT+=(
- 'random/tests/test_extending.py::test_cython'
- )
- fi
-
- rm -rf numpy || die
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest --pyargs numpy
-}
-
-python_install_all() {
- local DOCS=( LICENSE.txt README.md THANKS.txt )
- distutils-r1_python_install_all
-}