summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-03-05 08:28:40 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-03-10 23:35:00 +0100
commit36832db277da15cfa5c892d948370f5950370e8e (patch)
tree4f3e21d926c1e2b6ab65e08735631bc662ad192c /dev-python/openpyxl
parentdev-libs/openssl: Stable for HPPA too (diff)
downloadgentoo-36832db277da15cfa5c892d948370f5950370e8e.tar.gz
gentoo-36832db277da15cfa5c892d948370f5950370e8e.tar.bz2
gentoo-36832db277da15cfa5c892d948370f5950370e8e.zip
dev-python/openpyxl: version bump to 2.6.1 and EAPI 7.
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11265 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/Manifest1
-rw-r--r--dev-python/openpyxl/openpyxl-2.6.1.ebuild37
-rw-r--r--dev-python/openpyxl/openpyxl-9999.ebuild2
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/openpyxl/Manifest b/dev-python/openpyxl/Manifest
index 14b753e669cf..56e4d568de66 100644
--- a/dev-python/openpyxl/Manifest
+++ b/dev-python/openpyxl/Manifest
@@ -1 +1,2 @@
DIST openpyxl-2.4.11.tar.bz2 2139621 BLAKE2B 44fe7e471b50deabdea10e677e3b30f2eee62c661203517321e32442639e884c93ff3c4b6e7a0e5c5186bc8320c53d912832d955882b8cdb29c81d8319077c7c SHA512 9d1f9a3cadefec42bd7b6301bc3a37045e59e567a9f74eed3467547e81f060cf1c0ce2fc7f517911cd7f5716a42135a8567a0e0edc42eae0cc0c7a2370b320ae
+DIST openpyxl-2.6.1.tar.bz2 2403827 BLAKE2B 26abdea047b4d283f3d0e3ed499c1d7247d07b7a97426fd681d92798c7c49cc13fd53296e214d2c48e8461a80740a5ae600468bcf41c9cfd5b6f0b244ef3df93 SHA512 cf869b20ae8aeb068139eaddc8c915ba15405d531bc1a6e2b7c8068bad0ca628622c852cc1d4e11dfd8fab0078a9931fc33e5e47bda954b7cc994f60d79753fc
diff --git a/dev-python/openpyxl/openpyxl-2.6.1.ebuild b/dev-python/openpyxl/openpyxl-2.6.1.ebuild
new file mode 100644
index 000000000000..707b1dce67b3
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-2.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_COMMIT="134e08ea4301"
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+SRC_URI="https://bitbucket.org/${PN}/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${PN}-${PN}-${MY_COMMIT}"
+
+python_test() {
+ pytest -v || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/openpyxl/openpyxl-9999.ebuild b/dev-python/openpyxl/openpyxl-9999.ebuild
index 689dffb52654..01c0171d12e5 100644
--- a/dev-python/openpyxl/openpyxl-9999.ebuild
+++ b/dev-python/openpyxl/openpyxl-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1 mercurial