summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 14:49:07 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 14:49:28 +0200
commit4dd98aba7b81efe9aa3744c4f905097f0ec6ef2d (patch)
treed6f86471154c650f557b336fd4a9cf6858d8d258 /dev-python/paramiko
parentdev-python/packaging: Remove old (diff)
downloadgentoo-4dd98aba7b81efe9aa3744c4f905097f0ec6ef2d.tar.gz
gentoo-4dd98aba7b81efe9aa3744c4f905097f0ec6ef2d.tar.bz2
gentoo-4dd98aba7b81efe9aa3744c4f905097f0ec6ef2d.zip
dev-python/paramiko: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paramiko')
-rw-r--r--dev-python/paramiko/Manifest1
-rw-r--r--dev-python/paramiko/files/paramiko-2.4.2-disable-server.patch46
-rw-r--r--dev-python/paramiko/files/paramiko-3.0.0-nih-test-deps.patch98
-rw-r--r--dev-python/paramiko/paramiko-3.1.0-r1.ebuild55
4 files changed, 0 insertions, 200 deletions
diff --git a/dev-python/paramiko/Manifest b/dev-python/paramiko/Manifest
index 1b3bc344a812..0328ed4b9343 100644
--- a/dev-python/paramiko/Manifest
+++ b/dev-python/paramiko/Manifest
@@ -1,2 +1 @@
-DIST paramiko-3.1.0.gh.tar.gz 351910 BLAKE2B 7350626f3a8e54d8950085cbd8253f5564355abb4db7c65113c0df22674e3df0081da7299cfad779f1fcf9569b01720b6ab5dc2bde32c4a71500e79910caf4c8 SHA512 1a556a5b7a6ebc72a0c61b59f326a95c9f2784d74fdc1a171455867ba7b4b07a15741e168747b5a3a225685ad069e2d58021f54dadf7feb00f8acf65b0c07d51
DIST paramiko-3.2.0.gh.tar.gz 374709 BLAKE2B 80ec5678a51dc8a0eadd28228ae70a8912fb9a4be1807f5f65a925dd2252fd43ebba6f63b350b62ff7545d9ed0db6e4a78710fb73cff332e6d1ed996b0f1a7d9 SHA512 1d87a19284cef73a76eb7402d0492eb35d4a0588becd2f67ba19fe1498d6c10927127617398de11184d4865c8ce0f3e0c48194d50ef546414a17cf6faff3c39d
diff --git a/dev-python/paramiko/files/paramiko-2.4.2-disable-server.patch b/dev-python/paramiko/files/paramiko-2.4.2-disable-server.patch
deleted file mode 100644
index 19450cbee1bc..000000000000
--- a/dev-python/paramiko/files/paramiko-2.4.2-disable-server.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/paramiko/transport.py b/paramiko/transport.py
-index f72eebaf..ec7a1445 100644
---- a/paramiko/transport.py
-+++ b/paramiko/transport.py
-@@ -110,6 +110,8 @@ from paramiko.ssh_exception import (
- from paramiko.util import retry_on_signal, ClosingContextManager, clamp_value
-
-
-+SERVER_DISABLED_BY_GENTOO = True
-+
- # for thread cleanup
- _active_threads = []
-
-@@ -633,6 +635,8 @@ class Transport(threading.Thread, ClosingContextManager):
- `.SSHException` -- if negotiation fails (and no ``event`` was
- passed in)
- """
-+ if SERVER_DISABLED_BY_GENTOO:
-+ raise Exception("Disabled by Gentoo for security reasons. Enable with 'server' USE flag")
- if server is None:
- server = ServerInterface()
- self.server_mode = True
-diff --git a/tests/conftest.py b/tests/conftest.py
-index 2b509c5c..bb23ac74 100644
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -4,7 +4,7 @@ import shutil
- import threading
-
- import pytest
--from paramiko import RSAKey, SFTPServer, SFTP, Transport
-+from paramiko import RSAKey, SFTPServer, SFTP, Transport, transport
-
- from .loop import LoopSocket
- from .stub_sftp import StubServer, StubSFTPServer
-@@ -15,6 +15,10 @@ from .util import _support
- # 'nicer'.
-
-
-+# We need the server component for testing
-+transport.SERVER_DISABLED_BY_GENTOO = False
-+
-+
- # Perform logging by default; pytest will capture and thus hide it normally,
- # presenting it on error/failure. (But also allow turning it off when doing
- # very pinpoint debugging - e.g. using breakpoints, so you don't want output
diff --git a/dev-python/paramiko/files/paramiko-3.0.0-nih-test-deps.patch b/dev-python/paramiko/files/paramiko-3.0.0-nih-test-deps.patch
deleted file mode 100644
index 26b12f0ce154..000000000000
--- a/dev-python/paramiko/files/paramiko-3.0.0-nih-test-deps.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-From c7d1373554910102846123afb35c8c1a842f2c9a Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 17 May 2022 07:26:36 +0200
-Subject: [PATCH] Replace pytest-relaxed with plain pytest.raises
-
-There is really no technical reason to bring pytest-relaxed to call
-@raises as a decorator while plain pytest works just fine. Plus,
-pytest.raises() is used in test_sftp already.
-
-pytest-relaxed causes humongous breakage to other packages
-on the system. It has been banned from Gentoo for this reason.
----
- dev-requirements.txt | 6 ++++++
- pytest.ini | 3 ---
- tests/test_client.py | 19 +++++++++----------
- 3 files changed, 15 insertions(+), 13 deletions(-)
-
-diff --git a/tests/test_client.py b/tests/test_client.py
-index dae5b13a..d0e9c434 100644
---- a/tests/test_client.py
-+++ b/tests/test_client.py
-@@ -33,7 +33,6 @@ import weakref
- from tempfile import mkstemp
-
- import pytest
--from pytest_relaxed import raises
- from unittest.mock import patch, Mock
-
- import paramiko
-@@ -786,11 +785,11 @@ class PasswordPassphraseTests(ClientTest):
-
- # TODO: more granular exception pending #387; should be signaling "no auth
- # methods available" because no key and no password
-- @raises(SSHException)
- @requires_sha1_signing
- def test_passphrase_kwarg_not_used_for_password_auth(self):
-- # Using the "right" password in the "wrong" field shouldn't work.
-- self._test_connection(passphrase="pygmalion")
-+ with pytest.raises(SSHException):
-+ # Using the "right" password in the "wrong" field shouldn't work.
-+ self._test_connection(passphrase="pygmalion")
-
- @requires_sha1_signing
- def test_passphrase_kwarg_used_for_key_passphrase(self):
-@@ -810,15 +809,15 @@ class PasswordPassphraseTests(ClientTest):
- password="television",
- )
-
-- @raises(AuthenticationException) # TODO: more granular
- @requires_sha1_signing
- def test_password_kwarg_not_used_for_passphrase_when_passphrase_kwarg_given( # noqa
- self,
- ):
- # Sanity: if we're given both fields, the password field is NOT used as
- # a passphrase.
-- self._test_connection(
-- key_filename=_support("test_rsa_password.key"),
-- password="television",
-- passphrase="wat? lol no",
-- )
-+ with pytest.raises(AuthenticationException):
-+ self._test_connection(
-+ key_filename=_support("test_rsa_password.key"),
-+ password="television",
-+ passphrase="wat? lol no",
-+ )
---
-2.39.1
-
-From becd215434a7c01c74b407cbf2cbcb192e138a15 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 21 Jan 2023 06:56:09 +0100
-Subject: [PATCH] Remove icecream dep
-
----
- tests/conftest.py | 6 ------
- 1 file changed, 6 deletions(-)
-
-diff --git a/tests/conftest.py b/tests/conftest.py
-index b28d2a17..3cecb7e8 100644
---- a/tests/conftest.py
-+++ b/tests/conftest.py
-@@ -10,12 +10,6 @@ from .loop import LoopSocket
- from .stub_sftp import StubServer, StubSFTPServer
- from .util import _support
-
--from icecream import ic, install as install_ic
--
--
--install_ic()
--ic.configureOutput(includeContext=True)
--
-
- # Perform logging by default; pytest will capture and thus hide it normally,
- # presenting it on error/failure. (But also allow turning it off when doing
---
-2.39.1
-
diff --git a/dev-python/paramiko/paramiko-3.1.0-r1.ebuild b/dev-python/paramiko/paramiko-3.1.0-r1.ebuild
deleted file mode 100644
index 37c883ce58e8..000000000000
--- a/dev-python/paramiko/paramiko-3.1.0-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="SSH2 protocol library"
-HOMEPAGE="
- https://www.paramiko.org/
- https://github.com/paramiko/paramiko/
- https://pypi.org/project/paramiko/
-"
-SRC_URI="
- https://github.com/paramiko/paramiko/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="examples server"
-
-RDEPEND="
- >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
- >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/${PN}-3.0.0-nih-test-deps.patch"
- )
-
- if ! use server; then
- PATCHES+=( "${FILESDIR}/${PN}-2.4.2-disable-server.patch" )
- fi
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- docinto examples
- dodoc -r demos/*
- fi
-}