summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-22 20:16:56 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-22 20:16:56 +0300
commit5be42a3597e91b36057a92ffe5ac491f82162a62 (patch)
tree14142f0f1d9a4af5d6028e7d57a96b218431b991 /dev-python/paste
parentdev-python/pytoolconfig: new package, add 1.1.2 (diff)
downloadgentoo-5be42a3597e91b36057a92ffe5ac491f82162a62.tar.gz
gentoo-5be42a3597e91b36057a92ffe5ac491f82162a62.tar.bz2
gentoo-5be42a3597e91b36057a92ffe5ac491f82162a62.zip
dev-python/paste: add 3.5.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/Manifest1
-rw-r--r--dev-python/paste/paste-3.5.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/paste/Manifest b/dev-python/paste/Manifest
index ffb588bfb63d..09761ae19781 100644
--- a/dev-python/paste/Manifest
+++ b/dev-python/paste/Manifest
@@ -1 +1,2 @@
DIST Paste-3.5.0.tar.gz 638021 BLAKE2B 6c8d856733245a7eef5782f8d6c1fe35093f5247cc76e86ab308f2d98a99ebaaef5309a9c402f1334707e042b52e52d7801723e9404ad0ae454b756b9df31dfb SHA512 a9f596d6fcd95f915990c16830caeb9c9a03412447597258c67a003fd485e2efd27798f2eb2de9978ac529292af4b55136de554bfb501e90f6185f55a6b0531b
+DIST Paste-3.5.1.tar.gz 637755 BLAKE2B fc5f4afc064ced52322f7c2cb20c84d24538bdd3a5dadf7b47f62dd8b64ed62a2925102b785e366bc9b9257835529ae226a4d291bebd40d70bda16be781613c6 SHA512 7ae39691bb6067309a12bf76e2a110913c7be6ddcda6215eaf0228144ff26a1c7b50500729b65e27652dc7a7edf6fe26bd144d261e8754d7af8bac495d4613f9
diff --git a/dev-python/paste/paste-3.5.1.ebuild b/dev-python/paste/paste-3.5.1.ebuild
new file mode 100644
index 000000000000..7b27623d9a37
--- /dev/null
+++ b/dev-python/paste/paste-3.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P="Paste-${PV}"
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="
+ https://pythonpaste.readthedocs.io/en/latest/
+ https://github.com/cdent/paste/
+ https://pypi.org/project/Paste/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris"
+
+RDEPEND="
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-paste
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/test_proxy.py
+ )
+
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # fails due to cgi deprecation warning
+ tests/test_cgiapp.py::test_form
+ )
+
+ epytest
+}