summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-09 19:46:04 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-09 20:43:15 +0200
commitfe334fa4a36b52c0b4abbe9aaced58062387e60e (patch)
tree6d1a962d378885e12d025db35483e229ae22d562 /dev-python/pastedeploy
parentdev-python/paste: Tested on py3.6 (diff)
downloadgentoo-fe334fa4a36b52c0b4abbe9aaced58062387e60e.tar.gz
gentoo-fe334fa4a36b52c0b4abbe9aaced58062387e60e.tar.bz2
gentoo-fe334fa4a36b52c0b4abbe9aaced58062387e60e.zip
dev-python/pastedeploy: Fix namespace support
Diffstat (limited to 'dev-python/pastedeploy')
-rw-r--r--dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild b/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..b6bdabca097b
--- /dev/null
+++ b/dev-python/pastedeploy/pastedeploy-1.5.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="http://pythonpaste.org/deploy/ https://pypi.python.org/pypi/PasteDeploy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dodoc docs/*.txt
+ find "${D}" -name '*.pth' -delete || die
+}