summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-28 08:24:43 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-28 08:24:43 +0100
commit9431cd44aa42f0c6740398134058648775394989 (patch)
tree2a78bcd1c5e4411b04d33dc6fcd8ecad67575f6c /dev-python/pbs-installer
parentdev-python/pbs-installer: Remove old (diff)
downloadgentoo-9431cd44aa42f0c6740398134058648775394989.tar.gz
gentoo-9431cd44aa42f0c6740398134058648775394989.tar.bz2
gentoo-9431cd44aa42f0c6740398134058648775394989.zip
dev-python/pbs-installer: Bump to 2024.12.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pbs-installer')
-rw-r--r--dev-python/pbs-installer/Manifest1
-rw-r--r--dev-python/pbs-installer/pbs-installer-2024.12.19.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pbs-installer/Manifest b/dev-python/pbs-installer/Manifest
index 3aafb7b87209..f7ca79ef478a 100644
--- a/dev-python/pbs-installer/Manifest
+++ b/dev-python/pbs-installer/Manifest
@@ -1 +1,2 @@
DIST pbs-installer-2024.10.16.gh.tar.gz 79499 BLAKE2B 749a0ecc54a4df1e5989eee54b874b92bd7592307fe9bc0a13aa77dea96dcec8b6ff7b5fcfd10e354eaad21054cbf264c718fa7d692c6ee2df348f9217ca89ca SHA512 1b6bfc64bf311d03cf318365b1d16968ac599b40b247970477d6555791407bc104813bd60f82e30d88a13cd37873fef269a98640ee301f86028e6ddf7d097958
+DIST pbs-installer-2024.12.19.gh.tar.gz 82721 BLAKE2B b6a6ed17b4d1e55d9160361f45d4f15b3f8f12a6fa97208a2428c0c9b7f3b3f46e846f01d03539df86f5a4b109623a12133169880445aa386623b3f9e74935c3 SHA512 481ce48d4ba823d13e6c488aa146725e7406baf7f1d42a8561273d69311174e032930fa5d4d9c4f6edd3ce9ea866320e0266763a2b8b8456ed2f052149eb892a
diff --git a/dev-python/pbs-installer/pbs-installer-2024.12.19.ebuild b/dev-python/pbs-installer/pbs-installer-2024.12.19.ebuild
new file mode 100644
index 000000000000..c2bbf1f95bc4
--- /dev/null
+++ b/dev-python/pbs-installer/pbs-installer-2024.12.19.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Installer for Python Build Standalone"
+HOMEPAGE="
+ https://pypi.org/project/pbs-installer/
+ https://github.com/frostming/pbs-installer/
+
+"
+SRC_URI="
+ https://github.com/frostming/pbs-installer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="
+ dev-python/zstandard[${PYTHON_USEDEP}]
+"
+
+# upstream does not provide any tests
+RESTRICT=test
+
+python_configure_all() {
+ export PDM_BUILD_SCM_VERSION=${PV}
+}