summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-18 15:41:42 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-18 15:46:50 +0200
commite33ac8432a3a43b04fd590ebe48af723e5978c15 (patch)
treeb8f1c5257fd8da212009f97883627ff98172eda1 /dev-python/pendulum
parentapp-portage/recover-broken-vdb: Use PEP517 build (diff)
downloadgentoo-e33ac8432a3a43b04fd590ebe48af723e5978c15.tar.gz
gentoo-e33ac8432a3a43b04fd590ebe48af723e5978c15.tar.bz2
gentoo-e33ac8432a3a43b04fd590ebe48af723e5978c15.zip
dev-python/pendulum: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pendulum')
-rw-r--r--dev-python/pendulum/Manifest2
-rw-r--r--dev-python/pendulum/pendulum-2.1.2-r2.ebuild (renamed from dev-python/pendulum/pendulum-2.1.2-r1.ebuild)21
2 files changed, 17 insertions, 6 deletions
diff --git a/dev-python/pendulum/Manifest b/dev-python/pendulum/Manifest
index 3e628f72f341..18d42cf9abe1 100644
--- a/dev-python/pendulum/Manifest
+++ b/dev-python/pendulum/Manifest
@@ -1 +1 @@
-DIST pendulum-2.1.2.tar.gz 159885 BLAKE2B c95cd131fc95a0d19ef11f180cc42126cb8a6ea3aaf4b3bbedbc5ce4c1b37a6624f2a1be92f1a6fd6b1f14f5d20fa5f32e8230f896ab7a216f02f00e85b98738 SHA512 c367320ade0d10b7eb9c880286176161b925d7df052f7de85ddd169594bbe778776ea74df451f00186df98be3e32b7399c68ca4b40123e2c456206410e3a1ab2
+DIST pendulum-2.1.2.gh.tar.gz 159885 BLAKE2B c95cd131fc95a0d19ef11f180cc42126cb8a6ea3aaf4b3bbedbc5ce4c1b37a6624f2a1be92f1a6fd6b1f14f5d20fa5f32e8230f896ab7a216f02f00e85b98738 SHA512 c367320ade0d10b7eb9c880286176161b925d7df052f7de85ddd169594bbe778776ea74df451f00186df98be3e32b7399c68ca4b40123e2c456206410e3a1ab2
diff --git a/dev-python/pendulum/pendulum-2.1.2-r1.ebuild b/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
index 602bea9a4764..8ed0456d4293 100644
--- a/dev-python/pendulum/pendulum-2.1.2-r1.ebuild
+++ b/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
@@ -3,13 +3,21 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+DISTUTILS_USE_PEP517=poetry
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1
DESCRIPTION="Drop-in replacement for the standard datetime class"
-HOMEPAGE="https://pendulum.eustace.io/ https://github.com/sdispater/pendulum"
-SRC_URI="https://github.com/sdispater/pendulum/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://pendulum.eustace.io/
+ https://github.com/sdispater/pendulum/
+ https://pypi.org/project/pendulum/
+"
+SRC_URI="
+ https://github.com/sdispater/pendulum/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -19,12 +27,15 @@ DEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pytzdata[${PYTHON_USEDEP}]
"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ ${DEPEND}
+"
BDEPEND="
test? (
dev-python/Babel[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest