summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-30 15:42:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-30 15:42:38 +0100
commit59def6df0b051aa6358fe3ac8d49e2e4c60b081d (patch)
tree11aa92a6f1cb1a7c3c25ea79c9d08540bdece6ba /dev-python/pgspecial
parentdev-python/pgspecial: Stabilize 2.1.1 ALLARCHES, #918788 (diff)
downloadgentoo-59def6df0b051aa6358fe3ac8d49e2e4c60b081d.tar.gz
gentoo-59def6df0b051aa6358fe3ac8d49e2e4c60b081d.tar.bz2
gentoo-59def6df0b051aa6358fe3ac8d49e2e4c60b081d.zip
dev-python/pgspecial: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pgspecial')
-rw-r--r--dev-python/pgspecial/Manifest1
-rw-r--r--dev-python/pgspecial/pgspecial-2.1.0.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/pgspecial/Manifest b/dev-python/pgspecial/Manifest
index 986e37142784..b4b50f5ac035 100644
--- a/dev-python/pgspecial/Manifest
+++ b/dev-python/pgspecial/Manifest
@@ -1,2 +1 @@
-DIST pgspecial-2.1.0.tar.gz 50495 BLAKE2B 981f5a01ef32090eae7d477d23476fd8dd2a5bd3a5f3781e990cdbd28ebb24e5176653b7c8f9a1b7f1f01888a5c8278568257a709a5337f8b0d9838bfba8a21a SHA512 5bbd53d21ad89698b6ca04c989aa1ed59f3b8adc9b876b5b7db35bca03b964f645df2af96d3ddf6e7718c8ee06953fcf8f3ca548e65d722eaf4ea0098fa126ad
DIST pgspecial-2.1.1.tar.gz 51017 BLAKE2B 170db33ca1629244b2c8c2d23a5768528e474660dcaf73079c516d33624202cc05487a338b21ac5bab28780d127923bf24d86231e85cade2f82714add5bdd789 SHA512 4ab8596536b90837c2ed0a11b6bbfecd6e5dc487b073a58a1406e8e70028ebb7010430784963fe27a08a5cc48292785f6d02affb750f4a1b74cbe33a0e06a5f0
diff --git a/dev-python/pgspecial/pgspecial-2.1.0.ebuild b/dev-python/pgspecial/pgspecial-2.1.0.ebuild
deleted file mode 100644
index 56d59aaa9449..000000000000
--- a/dev-python/pgspecial/pgspecial-2.1.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python implementation of PostgreSQL meta commands"
-HOMEPAGE="
- https://github.com/dbcli/pgspecial/
- https://pypi.org/project/pgspecial/
-"
-
-LICENSE="BSD MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- >=dev-python/click-4.1[${PYTHON_USEDEP}]
- >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
- >=dev-python/psycopg-3.0.10:0[${PYTHON_USEDEP}]
- >=dev-python/sqlparse-0.1.19[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-db/postgresql-8.1[server]
- )
-"
-
-distutils_enable_tests pytest
-
-DOCS=( License.txt README.rst changelog.rst )
-
-EPYTEST_DESELECT=(
- # assumes a very specific locale
- tests/test_specials.py::test_slash_l
- tests/test_specials.py::test_slash_l_pattern
-)
-
-src_test() {
- local db=${T}/pgsql
-
- initdb --username=postgres -D "${db}" || die
- # TODO: random port
- pg_ctl -w -D "${db}" start \
- -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
- psql -h "${T}" -U postgres -d postgres \
- -c "ALTER ROLE postgres WITH PASSWORD 'postgres';" || die
- createdb -h "${T}" -U postgres _test_db || die
-
- distutils-r1_src_test
-
- pg_ctl -w -D "${db}" stop || die
-}