summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-02 06:35:34 +0000
committerSam James <sam@gentoo.org>2024-02-02 06:38:38 +0000
commit6b2035cc40486c28490f3c3610737219d90be5f3 (patch)
treed2aa3423bd14f8568f874558ce5c68736dc5a46d /dev-python/pkgcraft
parentdev-libs/libp11: update allowed versions of openssl (diff)
downloadgentoo-6b2035cc40486c28490f3c3610737219d90be5f3.tar.gz
gentoo-6b2035cc40486c28490f3c3610737219d90be5f3.tar.bz2
gentoo-6b2035cc40486c28490f3c3610737219d90be5f3.zip
dev-python/pkgcraft: add 0.0.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pkgcraft')
-rw-r--r--dev-python/pkgcraft/Manifest1
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.9.ebuild81
-rw-r--r--dev-python/pkgcraft/pkgcraft-9999.ebuild4
3 files changed, 84 insertions, 2 deletions
diff --git a/dev-python/pkgcraft/Manifest b/dev-python/pkgcraft/Manifest
index be76ce9fbe39..83fcb67b83dd 100644
--- a/dev-python/pkgcraft/Manifest
+++ b/dev-python/pkgcraft/Manifest
@@ -1 +1,2 @@
DIST pkgcraft-0.0.8.tar.gz 416513 BLAKE2B 8bf16807990344777981f21efe91fc57503f56a0f55c9be3eef9d407d09e9f3601318b7191968fa379fd31f4c9b0bee37e6af68ae792d9398735cf0298165495 SHA512 bfa049ecb003574bcb77fc7f76b58cb2ded8163888bd08ac982fefb8ec4f8cccb51a16f1e1cbffdc0da83965927fdc918983bc8b48b99b3cd43bb697aa6107dd
+DIST pkgcraft-0.0.9.tar.gz 431872 BLAKE2B 6c6ed1677c891c0e5579c7e28342876c2d7cbe03f2fcf3f8ad9f994302570d1d2398d2b4a55ec1a2fd82bbea518a4d2f76e9cabe760f0d9779b8d55170c1d940 SHA512 13988ff6822a5f9b715f3a9e8593a21d6ac530a91ca98790bd8a1c3e5958c97e440ce0610d25ed518f6d485837c9aded2ba145facf98e217325802777a33b3a7
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.9.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.9.ebuild
new file mode 100644
index 000000000000..b61769cf7136
--- /dev/null
+++ b/dev-python/pkgcraft/pkgcraft-0.0.9.ebuild
@@ -0,0 +1,81 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for pkgcraft"
+HOMEPAGE="
+ https://pypi.org/project/pkgcraft/
+ https://github.com/pkgcraft/pkgcraft-python/
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python.git"
+ inherit git-r3
+
+ PKGCRAFT_VERSION_MAX="99999" # extra 9 here or 9999 isn't mergable per DEPEND below
+ PKGCRAFT_VERSION_MIN="9999"
+else
+ SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
+ S="${WORKDIR}"/${P/-python}
+
+ KEYWORDS="~amd64 ~arm64"
+
+ PKGCRAFT_VERSION_MAX="9999"
+ PKGCRAFT_VERSION_MIN="0.0.14"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+examples"
+
+DEPEND="
+ <sys-libs/pkgcraft-${PKGCRAFT_VERSION_MAX}
+ >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if [[ ${PV} != 9999 ]] ; then
+ local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
+ if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
+ eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
+ eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
+ die "Mismatch between setup.py's MIN_VERSION and ebuild!"
+ fi
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install() {
+ # Conditional because these aren't installed officially right now
+ # and the naming is just for convenience.
+ if use examples ; then
+ while IFS= read -r -d '' file ; do
+ python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
+ done < <(find "${S}"/examples -type f -executable -print0 || die)
+ fi
+
+ distutils-r1_python_install
+}
diff --git a/dev-python/pkgcraft/pkgcraft-9999.ebuild b/dev-python/pkgcraft/pkgcraft-9999.ebuild
index 1e6dfefa9b31..b61769cf7136 100644
--- a/dev-python/pkgcraft/pkgcraft-9999.ebuild
+++ b/dev-python/pkgcraft/pkgcraft-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -28,7 +28,7 @@ else
KEYWORDS="~amd64 ~arm64"
PKGCRAFT_VERSION_MAX="9999"
- PKGCRAFT_VERSION_MIN="0.0.13"
+ PKGCRAFT_VERSION_MIN="0.0.14"
fi
LICENSE="MIT"