summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-27 04:42:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-27 05:10:37 +0200
commit3ca761bba9f9f00d7ee59bf4c40f6f1974e3bd4d (patch)
treef3109b9a62edd577bd2f9750613438a6e2ba256e /dev-python/platformdirs
parentdev-python/github3-py: Bump to 4.0.1 (diff)
downloadgentoo-3ca761bba9f9f00d7ee59bf4c40f6f1974e3bd4d.tar.gz
gentoo-3ca761bba9f9f00d7ee59bf4c40f6f1974e3bd4d.tar.bz2
gentoo-3ca761bba9f9f00d7ee59bf4c40f6f1974e3bd4d.zip
dev-python/platformdirs: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-3.4.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index c7f74ef45c62..39174b9e18d3 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1,2 +1,3 @@
DIST platformdirs-3.2.0.tar.gz 15017 BLAKE2B ce9f180965e0736ae83170b3a055dbb58e2ce59b84a414cd212f0f2f27a6a0a194636d315a30e344046ee1da85f2de3d2e7c58c02a329c4a36129fa617d8feb6 SHA512 2e4613f563b7014b526e1f81f561726a0060983b0e998ce46d070b2f4f4ec26ad46d6a3cd242fb14a420e6439207b9c9eeb31daac7ec65005abc3a74131e5cf8
DIST platformdirs-3.3.0.tar.gz 15459 BLAKE2B 46b59ce32b262feef1e045803b79c64ade18917dac34b11bd34ec8a6c872e9871df948532e10a8c4ebfbfddf2592243d8f8be6b24a84e75c08c5948068337f94 SHA512 c7530daf27072b0dea2d9bdb2fd764fb1f19daa735b199d3361579ffed709ba55392502600f73b8433e2651d36711dc264cf60a6fa50f29d9249b1e9808e35a3
+DIST platformdirs-3.4.0.tar.gz 15735 BLAKE2B 6297b04dd8720ffa0af1899c2c8081c836d23d0526e6510a81fa727ca42d5006709d6e8bd583f09aade09f603c4489e21468b8c66d848220c8c6f1de37535e97 SHA512 e98648b5065cdb3b75c183548b4143c6564292e4ec283710490fd019a2e72f6207ac6af6617e192aadf17b521eebc18126bf4b69fac227ac3cda4b768ce109da
diff --git a/dev-python/platformdirs/platformdirs-3.4.0.ebuild b/dev-python/platformdirs/platformdirs-3.4.0.ebuild
new file mode 100644
index 000000000000..58e26b5de925
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-3.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}