summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-12 04:24:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-12 04:24:36 +0200
commit77f9435db8f8ed37a5ffd71bbab3d82956388b88 (patch)
treec204887bcaa1a8d5eb38a431caeb2729b2bd386f /dev-python/platformdirs
parentapp-admin/awscli: Bump to 1.27.133 (diff)
downloadgentoo-77f9435db8f8ed37a5ffd71bbab3d82956388b88.tar.gz
gentoo-77f9435db8f8ed37a5ffd71bbab3d82956388b88.tar.bz2
gentoo-77f9435db8f8ed37a5ffd71bbab3d82956388b88.zip
dev-python/platformdirs: Bump to 3.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-3.5.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index a24dfe124b49..4e9786ade267 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -2,3 +2,4 @@ DIST platformdirs-3.2.0.tar.gz 15017 BLAKE2B ce9f180965e0736ae83170b3a055dbb58e2
DIST platformdirs-3.3.0.tar.gz 15459 BLAKE2B 46b59ce32b262feef1e045803b79c64ade18917dac34b11bd34ec8a6c872e9871df948532e10a8c4ebfbfddf2592243d8f8be6b24a84e75c08c5948068337f94 SHA512 c7530daf27072b0dea2d9bdb2fd764fb1f19daa735b199d3361579ffed709ba55392502600f73b8433e2651d36711dc264cf60a6fa50f29d9249b1e9808e35a3
DIST platformdirs-3.4.0.tar.gz 15735 BLAKE2B 6297b04dd8720ffa0af1899c2c8081c836d23d0526e6510a81fa727ca42d5006709d6e8bd583f09aade09f603c4489e21468b8c66d848220c8c6f1de37535e97 SHA512 e98648b5065cdb3b75c183548b4143c6564292e4ec283710490fd019a2e72f6207ac6af6617e192aadf17b521eebc18126bf4b69fac227ac3cda4b768ce109da
DIST platformdirs-3.5.0.tar.gz 16037 BLAKE2B eef04e650c8028b87cc90fce02aed9259a6e4317b8445c429bbef1cb2ff1e6e6aae3c6dba38be2fed2e443cb4a7dc8c783345435ae922d0632e14823d7b80bfc SHA512 2c454a760b3045f4824b1c436ac85533e7a6809e4525d70cee4d98289f9efc5a882384347a1992aaa237dc29ea8e778515eadeca208a2d058f9e574f5175ce20
+DIST platformdirs-3.5.1.tar.gz 17164 BLAKE2B 7d9aeff02000b75a028e6f75dc4793e53bbe72b5fc069482d5790d9280a92b801dffca847fe64513b8ee3d24b5639681cb1cfcb1f97d85e8e996c7f6cbca2f71 SHA512 e3aa38bc943f9dc709dfaa3c6fe9e11f3b33d4263d1d41f7349d9926db2e41a36dd43c74ea2175ad89b107601f2dffded0f45e7703b9cb8ca9739945dee3c6fb
diff --git a/dev-python/platformdirs/platformdirs-3.5.1.ebuild b/dev-python/platformdirs/platformdirs-3.5.1.ebuild
new file mode 100644
index 000000000000..58e26b5de925
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-3.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}