summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-31 08:40:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-31 08:53:04 +0100
commitcddb9442c035363af2a3de5e09aab92ba6ca9a1b (patch)
treed71f707af4b53c263594596c0372f8194a0c0ec9 /dev-python/prometheus-client
parentdev-python/cfn-lint: Bump to 0.83.1 (diff)
downloadgentoo-cddb9442c035363af2a3de5e09aab92ba6ca9a1b.tar.gz
gentoo-cddb9442c035363af2a3de5e09aab92ba6ca9a1b.tar.bz2
gentoo-cddb9442c035363af2a3de5e09aab92ba6ca9a1b.zip
dev-python/prometheus-client: Bump to 0.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prometheus-client')
-rw-r--r--dev-python/prometheus-client/Manifest1
-rw-r--r--dev-python/prometheus-client/prometheus-client-0.18.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/prometheus-client/Manifest b/dev-python/prometheus-client/Manifest
index 1190f5f33acb..30fcf10e9c98 100644
--- a/dev-python/prometheus-client/Manifest
+++ b/dev-python/prometheus-client/Manifest
@@ -1 +1,2 @@
DIST prometheus_client-0.17.1.tar.gz 90360 BLAKE2B 3927d5b6829a04cd72a99ac3b0b6a12726865b41d17f165a53f83a6a3791f18e25e03995088152ac7eae016eab7c6e29bef1e605f4c444f9963be04483ca2f02 SHA512 c8c776d646ea4a18a85fd26c858158b67979173dcf52d0a337cdb87fe907ff4081d8e0771176ba8be0ea6e244ee9b9097396c9aeb6f6db170a2c0f5a4898c771
+DIST prometheus_client-0.18.0.tar.gz 92365 BLAKE2B 2443fda2ae6f23cc817d4adbb63799501d7e688c2f10b876ed7dbb0f5efdd31d5ca7300fefc059a65533205155682e567c31eebe3e10b173bde4c018a17c65c9 SHA512 97ae14d549b3559f8e8136f56cde593ed2ef6303577e98e6f20367589d5df0e9630e9c13accf57609dfbb364527632c665e21f0778b0fd14cea5446495432ffb
diff --git a/dev-python/prometheus-client/prometheus-client-0.18.0.ebuild b/dev-python/prometheus-client/prometheus-client-0.18.0.ebuild
new file mode 100644
index 000000000000..4c7172a015c2
--- /dev/null
+++ b/dev-python/prometheus-client/prometheus-client-0.18.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="
+ https://github.com/prometheus/client_python/
+ https://pypi.org/project/prometheus-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest