summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-07 07:39:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-07 08:23:02 +0200
commit5751497c91f48d8ed01605c30b10f940567722f6 (patch)
tree3870780bfc133036f330ce8b681bfa9e54dad9ef /dev-python/pulsectl-asyncio
parentdev-python/yarl: Bump to 1.10.0 (diff)
downloadgentoo-5751497c91f48d8ed01605c30b10f940567722f6.tar.gz
gentoo-5751497c91f48d8ed01605c30b10f940567722f6.tar.bz2
gentoo-5751497c91f48d8ed01605c30b10f940567722f6.zip
dev-python/pulsectl-asyncio: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pulsectl-asyncio')
-rw-r--r--dev-python/pulsectl-asyncio/Manifest1
-rw-r--r--dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pulsectl-asyncio/Manifest b/dev-python/pulsectl-asyncio/Manifest
index fb2b24db043b..bd9d822b3bb4 100644
--- a/dev-python/pulsectl-asyncio/Manifest
+++ b/dev-python/pulsectl-asyncio/Manifest
@@ -1 +1,2 @@
DIST pulsectl-asyncio-1.2.0.gh.tar.gz 19517 BLAKE2B 919909acfabfefa1dbea99cef6285483652649c111df6f3f6719d92e35ea548b54e6c0a60e4277b69610ee9a58c2c29c3355b7f2fe2780d773aa2c89513ce9a1 SHA512 b560c38b6d18a4c73551ae4ba34243f0043dc18426141c128c6ca3e8bd30f4d94d8718c3003ae506be038bc645ee569b77e6289b97ac913daa1e42e6b9aef03b
+DIST pulsectl-asyncio-1.2.1.gh.tar.gz 19531 BLAKE2B 4a3275d75602907f91b3a0979ff8908f4fa23bcf5d1d04068f878fc477011258180cec8ef16b6e6ebe6cc1713ff493841686cc67c4990222c061aa1b722199ff SHA512 b22d0a634433d558860ff1590020ba7272412be97da478a8b00ec457506cb58353b645537ae26591f1aed300cacc14fd0f50c8a3a0c7d650d610b24cc52248ee
diff --git a/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.1.ebuild b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.1.ebuild
new file mode 100644
index 000000000000..8b6cfcbfc7dc
--- /dev/null
+++ b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asyncio frontend for pulsectl, Python bindings of libpulse"
+HOMEPAGE="
+ https://github.com/mhthies/pulsectl-asyncio/
+ https://pypi.org/project/pulsectl-asyncio/
+"
+# sdist is missing examples that are used in tests
+SRC_URI="
+ https://github.com/mhthies/pulsectl-asyncio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pulsectl-23.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:,<=[0-9.]*::' setup.cfg || die
+ distutils-r1_src_prepare
+}