summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 09:47:47 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 09:47:47 +0100
commit63f9e7ae72516cb17bf6b299a864a57e1e57bd32 (patch)
tree5b801af128e92ac8ae20a77f52305e51c2408a62 /dev-python/pybind11
parentdev-python/pybind11: Remove broken docs support (diff)
downloadgentoo-63f9e7ae72516cb17bf6b299a864a57e1e57bd32.tar.gz
gentoo-63f9e7ae72516cb17bf6b299a864a57e1e57bd32.tar.bz2
gentoo-63f9e7ae72516cb17bf6b299a864a57e1e57bd32.zip
dev-python/pybind11: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pybind11')
-rw-r--r--dev-python/pybind11/Manifest1
-rw-r--r--dev-python/pybind11/pybind11-2.5.0.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pybind11/Manifest b/dev-python/pybind11/Manifest
index 85838cd0efd5..591e3dea050b 100644
--- a/dev-python/pybind11/Manifest
+++ b/dev-python/pybind11/Manifest
@@ -1,4 +1,3 @@
-DIST pybind11-2.5.0.tar.gz 573769 BLAKE2B e46d99f873f8266efc577d3e0ab1e8a78784a45c35995bc3486501d627698e0fb10205008e8cb82c84e971f20cd02a6d2f08390f3a3041fff1a21c45f11b197f SHA512 7f3a9c71916749436898d1844ef6b112baf0817a386308b5df8dec2a912ef4b6a932b94965e98f227c49fa77312f131972a6039f23b84a3daf6442a8ab0be7c2
DIST pybind11-2.6.0.tar.gz 631925 BLAKE2B 6b7872182f52e035f2a86f0f2ad70b084e62fc20d5aae4903c13ff824f80f3815845f3206d740d17ae471fd979eca117d9d4ee011f9f96c319ca808e6304b07f SHA512 6a3f407c136d827243c0043c794c654ca267a1a4e3b7e0e45cc7629e29193156b0744d85e45222fab284a9af82cf7fa2008fbd977d2b5a7b947c8a6581456caf
DIST pybind11-2.6.1.tar.gz 634179 BLAKE2B 33f057e88e45985a0475783b8931ec669a16efcad5d66ecb265744155e9941b2d618391a36bff1d8c1c2d74a7e0b41de50b26eae689215d4585542fbd4282cc1 SHA512 8730efec82eef8dc09a58ca3e3b28fca45880cef85d32aa5524a8fe64e23d5f6dff4ca1b48b3034a287199bd56f4db4d6806c5358bef66fde84ed0fbf80ec264
DIST pybind11-2.6.2.tar.gz 647954 BLAKE2B e336d626d314538123a121d48998b15d9d16b80a6a513e85b4ef2b3179f73732ef23b85ab91d815f15c31f7e2c5091192e90b9ff8e727725882963a895367612 SHA512 1eb346ff6b8f827053265340925e2c8038b1e2a89c352fc09f15ebe86128e7ba1f48c4368b193941f034b30bee7f72a94343e05d4841fdbbd0e4d91ed3d32025
diff --git a/dev-python/pybind11/pybind11-2.5.0.ebuild b/dev-python/pybind11/pybind11-2.5.0.ebuild
deleted file mode 100644
index 01814f6a79fc..000000000000
--- a/dev-python/pybind11/pybind11-2.5.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit cmake distutils-r1
-
-DESCRIPTION="AST-based Python refactoring library"
-HOMEPAGE="https://pybind11.readthedocs.io/en/stable/"
-SRC_URI="https://github.com/pybind/pybind11/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-RDEPEND="
- dev-cpp/eigen:3
-"
-
-distutils_enable_sphinx docs \
- '<dev-python/sphinx-3' \
- dev-python/breathe \
- dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-DOCS=( README.md CONTRIBUTING.md ISSUE_TEMPLATE.md )
-
-python_prepare_all() {
- export PYBIND11_USE_CMAKE=1
-
- # broken with scipy-1.4.1
- sed -i -e 's:test_sparse:_&:' tests/test_eigen.py || die
-
- cmake_src_prepare
- distutils-r1_python_prepare_all
-}
-
-python_configure() {
- local mycmakeargs=(
- # disable forced lto
- -DPYBIND11_LTO_CXX_FLAGS=
- -DPYBIND11_INSTALL=ON
- -DPYBIND11_TEST=$(usex test)
- )
- cmake_src_configure
-}
-
-python_compile() {
- distutils-r1_python_compile
- # Compilation only does anything for tests
- use test && cmake_src_compile
-}
-
-python_test() {
- cmake_build check
-}
-
-python_install() {
- distutils-r1_python_install
- cmake_src_install
-}