summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-29 08:55:14 +0200
committerMichał Górny <mgorny@gentoo.org>2018-03-29 08:55:51 +0200
commitb06e56c13ad628b1910ac94387a202df23595532 (patch)
treeaa5800d54764e84e8240991d4e087c3565de2b7b /dev-python/pyblake2
parentdev-ruby/timecop: add ruby25 (diff)
downloadgentoo-b06e56c13ad628b1910ac94387a202df23595532.tar.gz
gentoo-b06e56c13ad628b1910ac94387a202df23595532.tar.bz2
gentoo-b06e56c13ad628b1910ac94387a202df23595532.zip
dev-python/pyblake2: Bump to 1.1.1, now with pypy3 support
Diffstat (limited to 'dev-python/pyblake2')
-rw-r--r--dev-python/pyblake2/Manifest1
-rw-r--r--dev-python/pyblake2/pyblake2-1.1.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyblake2/Manifest b/dev-python/pyblake2/Manifest
index 28d0d5891578..dc51d3bdacdb 100644
--- a/dev-python/pyblake2/Manifest
+++ b/dev-python/pyblake2/Manifest
@@ -1 +1,2 @@
DIST pyblake2-1.1.0.tar.gz 125855 BLAKE2B 46af4c24882040bbdd221f90e06652918798e4555c0a7307a596ca4c9ed3147f00297269a44d174782c2b0402eac03ecf5387b1c5a16efb57d036730b58b2630 SHA512 e13c7e4f3a35155cbf531e337895349ec01f0ac36908a4e746cecec063601adfc8a73a7961a9c310d01d3231f44f08d2cc92e891e9cb87659bc7170b9fee6102
+DIST pyblake2-1.1.1.tar.gz 126441 BLAKE2B cb1f1872e1d6122419e7732114da28162af5e483db56e073d3cc4019f073813af747d56ca4f4a992cf6586d12662f3b1d4b68d04eaea91b4f90de58a9c1f4799 SHA512 a876255d0072226c4a2936a9e88297dc8c39195f423fea6624e6ffd610ffc58d07e939db942d0198d6e5a1f1afc892103c507f226787529d341ae40e9926bcac
diff --git a/dev-python/pyblake2/pyblake2-1.1.1.ebuild b/dev-python/pyblake2/pyblake2-1.1.1.ebuild
new file mode 100644
index 000000000000..1c7cc912307d
--- /dev/null
+++ b/dev-python/pyblake2/pyblake2-1.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+inherit distutils-r1
+
+DESCRIPTION="BLAKE2 hash function extension module"
+HOMEPAGE="https://github.com/dchest/pyblake2 https://pypi.python.org/pypi/pyblake2"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+# pyblake2 itself allows more licenses but blake2 allows the following three
+LICENSE="|| ( CC0-1.0 openssl Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" test/test.py || die "Tests fail with ${EPYTHON}"
+}