summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-02 04:31:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-02 04:34:59 +0200
commit7905e55f7a7f33343877b187b9efdc90bfd39a23 (patch)
tree54ff4ae66d32ac40b1b48d4712ccc83b7835a6de /dev-python/pycountry/pycountry-24.6.1.ebuild
parentdev-python/pyscard: Bump to 2.0.10 (diff)
downloadgentoo-7905e55f7a7f33343877b187b9efdc90bfd39a23.tar.gz
gentoo-7905e55f7a7f33343877b187b9efdc90bfd39a23.tar.bz2
gentoo-7905e55f7a7f33343877b187b9efdc90bfd39a23.zip
dev-python/pycountry: Bump to 24.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycountry/pycountry-24.6.1.ebuild')
-rw-r--r--dev-python/pycountry/pycountry-24.6.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pycountry/pycountry-24.6.1.ebuild b/dev-python/pycountry/pycountry-24.6.1.ebuild
new file mode 100644
index 000000000000..48fbe8ffcd2a
--- /dev/null
+++ b/dev-python/pycountry/pycountry-24.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="
+ https://github.com/pycountry/pycountry/
+ https://pypi.org/project/pycountry/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -o required_plugins=
+}