summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-27 06:29:22 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-27 06:38:15 +0100
commitc629fe4dac9c5200c2e7eaa5338855d5f5cc2bda (patch)
tree0c6ae127846dd927059e0a7a938f98e5251f0cc2 /dev-python/pycurl
parentdev-python/mkdocs-material: Bump to 9.0.15 (diff)
downloadgentoo-c629fe4dac9c5200c2e7eaa5338855d5f5cc2bda.tar.gz
gentoo-c629fe4dac9c5200c2e7eaa5338855d5f5cc2bda.tar.bz2
gentoo-c629fe4dac9c5200c2e7eaa5338855d5f5cc2bda.zip
dev-python/pycurl: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycurl')
-rw-r--r--dev-python/pycurl/Manifest1
-rw-r--r--dev-python/pycurl/files/7.44-fix-tests.patch34
-rw-r--r--dev-python/pycurl/pycurl-7.45.1.ebuild93
3 files changed, 0 insertions, 128 deletions
diff --git a/dev-python/pycurl/Manifest b/dev-python/pycurl/Manifest
index 876ac8788f96..12303b7d4f75 100644
--- a/dev-python/pycurl/Manifest
+++ b/dev-python/pycurl/Manifest
@@ -1,2 +1 @@
-DIST pycurl-7.45.1.tar.gz 233879 BLAKE2B 8a6fe72f00cfd172b4f5e257f4526c4115047aa911d7fb3802d3bf105ac70dc866b27fa4878aae9f92229a5dd5108a2b5e1c9acfe93e1a94dac60d9405c5d5e6 SHA512 05639d484aac6d6688677589e391975158c5ef778456a47df575ad13fb8bd0db67ff8f5a39bdd99d82a67926aca421c01e687eec9d4fd87f32822b492b429635
DIST pycurl-7.45.2.tar.gz 234245 BLAKE2B 16257a967d2867de08d83478f602d00b54316d37b6a544804e606a814f61507530fb7e1ef3247be824dfa22b9487a69bbfc9b1038b2b776ebc556b18ed2d93ca SHA512 8a82346395acfc0bd37a8c4d8d2b17e5ab4602710308ed50f9ed88c223c73f15f5b1c95fc6191708e3bd9d647e4bc5ec91f740de433dd87e2ae0796ac79879ac
diff --git a/dev-python/pycurl/files/7.44-fix-tests.patch b/dev-python/pycurl/files/7.44-fix-tests.patch
deleted file mode 100644
index d5d900100086..000000000000
--- a/dev-python/pycurl/files/7.44-fix-tests.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-https://github.com/pycurl/pycurl/commit/d47c68b1364f8a1a45ab8c584c291d44b762f7b1
-From: Samuel Henrique <samueloph@debian.org>
-Date: Sat, 30 Apr 2022 23:02:34 +0100
-Subject: [PATCH] tests: fix error message on error_test (for curl >= 7.83)
-
-curl 7.83.0 removed exclamation marks from a few error messages, curl commit:
-https://github.com/curl/curl/commit/6968fb9d54dc3a1aaa1b16088f038eaf5dd8b2d7
-
-This commit adds support for the new curl release while also supporting the previous ones.
---- a/tests/error_test.py
-+++ b/tests/error_test.py
-@@ -29,7 +29,8 @@ def test_pycurl_error_libcurl(self):
- err, msg = exc.args
- self.assertEqual(pycurl.E_URL_MALFORMAT, err)
- # possibly fragile
-- self.assertEqual('No URL set!', msg)
-+ # curl < 7.83.0 has an exclamation mark in this error message
-+ self.assertIn(msg, ['No URL set!', 'No URL set'])
- else:
- self.fail('Expected pycurl.error to be raised')
-
-@@ -43,9 +44,10 @@ def test_pycurl_errstr_type(self):
- self.curl.perform()
- except pycurl.error:
- # might be fragile
-- self.assertEqual('No URL set!', self.curl.errstr())
-+ # curl < 7.83.0 has an exclamation mark in this error message
-+ self.assertIn(self.curl.errstr(), ['No URL set!', 'No URL set'])
- # repeated checks do not clear value
-- self.assertEqual('No URL set!', self.curl.errstr())
-+ self.assertIn(self.curl.errstr(), ['No URL set!', 'No URL set'])
- # check the type - on all python versions
- self.assertEqual(str, type(self.curl.errstr()))
- else:
diff --git a/dev-python/pycurl/pycurl-7.45.1.ebuild b/dev-python/pycurl/pycurl-7.45.1.ebuild
deleted file mode 100644
index d8fd41fb47b5..000000000000
--- a/dev-python/pycurl/pycurl-7.45.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Python bindings for curl/libcurl"
-HOMEPAGE="
- http://pycurl.io/
- https://github.com/pycurl/pycurl/
- https://pypi.org/project/pycurl/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl examples ssl"
-
-# Depend on a curl with curl_ssl_* USE flags.
-# libcurl must not be using an ssl backend we do not support.
-# If the libcurl ssl backend changes pycurl should be recompiled.
-# If curl uses gnutls, depend on at least gnutls 2.11.0 so that pycurl
-# does not need to initialize gcrypt threading and we do not need to
-# explicitly link to libgcrypt.
-DEPEND="
- >=net-misc/curl-7.25.0-r1:=[ssl=]
- ssl? (
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-)]
- curl_ssl_gnutls? ( >=net-libs/gnutls-2.11.0:= )
- curl_ssl_openssl? ( dev-libs/openssl:= )
- )
-"
-
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- test? (
- >=dev-python/bottle-0.12.7[${PYTHON_USEDEP}]
- dev-python/flaky[${PYTHON_USEDEP}]
- net-misc/curl[curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),http2]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/7.44-fix-tests.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # docs installed into the wrong directory
- sed -e "/setup_args\['data_files'\] = /d" -i setup.py || die
- # TODO
- sed -e 's:test_socks5_gssapi_nec_setopt:_&:' \
- -i tests/option_constants_test.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- # Override faulty detection in setup.py, bug #510974.
- export PYCURL_SSL_LIBRARY=${CURL_SSL}
-}
-
-src_test() {
- emake -C tests/fake-curl/libcurl CC="$(tc-getCC)"
-
- distutils-r1_src_test
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local EPYTEST_DESELECT=(
- # refcounting tests are unreliable
- tests/memory_mgmt_test.py::MemoryMgmtTest::test_readdata_refcounting
- tests/memory_mgmt_test.py::MemoryMgmtTest::test_writedata_refcounting
- tests/memory_mgmt_test.py::MemoryMgmtTest::test_writeheader_refcounting
- )
-
- epytest -p flaky tests
-}
-
-python_install_all() {
- local HTML_DOCS=( doc/. )
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}