summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-13 16:34:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-13 16:58:24 +0200
commit031875f96005cc922c651c2b9221103350fd1a0c (patch)
tree4e9ea13545053bfc11b1a241a0d0fd7a67f0c2ec /dev-python/pyfakefs
parentdev-python/zeep: Bump to 4.3.0 (diff)
downloadgentoo-031875f96005cc922c651c2b9221103350fd1a0c.tar.gz
gentoo-031875f96005cc922c651c2b9221103350fd1a0c.tar.bz2
gentoo-031875f96005cc922c651c2b9221103350fd1a0c.zip
dev-python/pyfakefs: Bump to 5.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.7.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 14db4cdcd62f..8545e29dfbba 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,3 +1,4 @@
DIST pyfakefs-5.3.5.gh.tar.gz 227359 BLAKE2B 635e41cb9892e1707555559769c01d5b575e44c5f1dd412acc05c3bed3b2dad2724ba32341b59cdecdfb658c94008e09396970349d8c1ffdcb90bf89ea82aca0 SHA512 342dc9cc0378af8cd8a9b0783fb6a1415207505ec8d4992f8fdd7e8d2bc4aada26d0803ed3b74d30b42a50dffb793c70acdeb3f28f199c0918783e1ea0a5e0d8
DIST pyfakefs-5.6.0.gh.tar.gz 242557 BLAKE2B d29e83d5ad6c7e313d28484754d2064d820856429c0e48e3b5851ecc1ae8cdfdc632f5855548229bc362b5323a7166b8d3776f2a2ccfb7472938362695a9f6f7 SHA512 7f3d8798088c66aaf57e238ee8f4693164508d23ff59fcde4a546af26da850a8c33cf0c552cb312ccfebbbbfc463db78ac80a356ce55634afc276124064ee210
DIST pyfakefs-5.7.0.gh.tar.gz 245747 BLAKE2B 08d3962cb801970b5b684e2f650f0b7db2679ff78a05a0cecf955c22420f3039f333c595bea01eb9a8235c22f45997494fe1a7cfbae2af61407448cc9d71ee1d SHA512 015d2e7007d6c7c72056f290fce150b107903620d616d2eed8de9fee601cf9d0719553cab0ad583f4444bf724279386c08b87c4585fb970266b359d7a2684f5a
+DIST pyfakefs-5.7.1.gh.tar.gz 245977 BLAKE2B 8d675ddeecdf2ebde938509da68e76b67773f490c65f99f67c25e781147fd0743e3ccd2f8083d36e29fd293ffb8a77182055abec4f03a10b64a39787b4b4330a SHA512 78a5e754fbc4a47f4816296cd7045cb9001924f3185297ba166d332e2a938eb3109684cd4b63761c7d56e5461a298405f4d20059a8806d059bc940a7e8443d77
diff --git a/dev-python/pyfakefs/pyfakefs-5.7.1.ebuild b/dev-python/pyfakefs/pyfakefs-5.7.1.ebuild
new file mode 100644
index 000000000000..20bdeee372a0
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ # test for regression with undefined package
+ pyfakefs/pytest_tests/pytest_fixture_test.py
+ )
+
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ pyfakefs/pytest_tests/pytest_reload_pandas_test.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}