summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-19 07:48:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-19 08:44:36 +0200
commitb9eb4884ee1bc3116e4861e226735c783124a81b (patch)
tree807dd54715ad1fe3c67a934f2375299d0fca4d12 /dev-python/pyfakefs
parentdev-python/dask: Bump to 2023.8.1 (diff)
downloadgentoo-b9eb4884ee1bc3116e4861e226735c783124a81b.tar.gz
gentoo-b9eb4884ee1bc3116e4861e226735c783124a81b.tar.bz2
gentoo-b9eb4884ee1bc3116e4861e226735c783124a81b.zip
dev-python/pyfakefs: Bump to 5.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest1
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.2.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 792ce1f912d4..84849dc1d808 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1 +1,2 @@
DIST pyfakefs-5.2.3.gh.tar.gz 222076 BLAKE2B 01d24021be074058d865ac068f77de69721ad2f826f835f04776e8d17a8f4cfaeb85bce9a948d679951b8f028ef6d6b3377428d76c5d2d46afea3b78dffcee1e SHA512 5e4adeecb1e2341f3dee20d48b387de870cdab4ad27791951f98ba516f8f4cbe4f5e303c83725c2ce5a9cfaf34f771814b07c553983eb283aa7c3fd7f4e7690d
+DIST pyfakefs-5.2.4.gh.tar.gz 222882 BLAKE2B 780f3952886dfb263be97fbcaa99ed0f0bcb804b075b71822d8a5b0db2bd1e12c57daf88b96d3eb8eb4b7fefdde6fb343cec8429bcf4380e4981bea7ca4f780d SHA512 2b933c420393b329d2c3ac6523e650124cce84424e298e1525591be02033d1bbb5d5cc354170ac6875d63e1729f6f79edcf8400d1cb0e419c586ae1cdd491baa
diff --git a/dev-python/pyfakefs/pyfakefs-5.2.4.ebuild b/dev-python/pyfakefs/pyfakefs-5.2.4.ebuild
new file mode 100644
index 000000000000..3c6dcae279a5
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}