summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-22 20:43:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-22 21:14:42 +0200
commit1f1ae5fd9d06a7e420d3cb494ea56be06717c1d3 (patch)
treec20ecf3460de3b2e86a6743f9f4f322c8e6f5245 /dev-python/pyhamcrest
parentpython-utils-r1.eclass: Disable pytest-describe by default (diff)
downloadgentoo-1f1ae5fd9d06a7e420d3cb494ea56be06717c1d3.tar.gz
gentoo-1f1ae5fd9d06a7e420d3cb494ea56be06717c1d3.tar.bz2
gentoo-1f1ae5fd9d06a7e420d3cb494ea56be06717c1d3.zip
dev-python/pyhamcrest: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest1
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index d9bbb9460f54..0170c93eca81 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1 +1,2 @@
DIST PyHamcrest-2.0.4.gh.tar.gz 59952 BLAKE2B 76d8bbe2581c178f26cabac5207b6f26f0e86d66848a51fb24d313fdafffc75d40a02f02a73462358ca55a6b50941f849c542340b854aed83a37cef5876d90e4 SHA512 6ee558fe04dce839d5d5d20b90ecf82fed96570e1c5b3a827fce19dba167bf4702ea707560b19e2d6e82be20913deb6cf17fa7e140733899a92abb28e9f2aa56
+DIST PyHamcrest-2.1.0.gh.tar.gz 62526 BLAKE2B 5f4a836c6f0e61977fe0d572987a75fa9803d2362afb95d27d22aa8a567844823452b99c40c8160cca4407a60dbbeff3f6fdf03163da9ee643e082a64e83c512 SHA512 99017a75954b346622f9bd261a4f8827f82eb42a19551a7f96f9097a763e57afcc367a41a4cca742bda60ee0e7c3bcc2ca7025348e318f41e67c97c7a60961b5
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
new file mode 100644
index 000000000000..d4de03edcdef
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="PyHamcrest-${PV}"
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="
+ https://github.com/hamcrest/PyHamcrest/
+ https://pypi.org/project/PyHamcrest/
+"
+SRC_URI="
+ https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}