summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-26 21:53:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-26 22:56:30 +0100
commita2b4158e46ed3acd567f7c03234ecbfef10f17f3 (patch)
tree8f7c914cc99d8797ed48a1865f9d196e9732e704 /dev-python/pylama
parentdev-python/hypothesis: Bump to 6.27.2 (diff)
downloadgentoo-a2b4158e46ed3acd567f7c03234ecbfef10f17f3.tar.gz
gentoo-a2b4158e46ed3acd567f7c03234ecbfef10f17f3.tar.bz2
gentoo-a2b4158e46ed3acd567f7c03234ecbfef10f17f3.zip
dev-python/pylama: Bump to 8.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylama')
-rw-r--r--dev-python/pylama/Manifest1
-rw-r--r--dev-python/pylama/pylama-8.0.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pylama/Manifest b/dev-python/pylama/Manifest
index 576f634fc64e..cd4f2f652077 100644
--- a/dev-python/pylama/Manifest
+++ b/dev-python/pylama/Manifest
@@ -1,2 +1,3 @@
DIST pylama-7.7.1.tar.gz 34740 BLAKE2B a4bd5aed40c2c4e7bdb9f9968030f0954f0309cff80567b2252ee9576fdb4598714286bda63c22676789d4919662430ef2729089faa70b5cb590784eb47ef1f0 SHA512 298fabffcdf38e3e868e3965de87a0e761bc9dfcfe33320b53057c4e05598bcc22045481ec16ccb8df27f49ea41d6fef82b69fe7327905f93ce74d9350682cf0
DIST pylama-8.0.4.tar.gz 34064 BLAKE2B e6ec937b7716d8a64c19e71b370e557a30d04d908ed2d1859df380c381a7eea93956ec4b58ca779e6029119a017ffce268a5528424783b33e815827dacb79b5d SHA512 c2ad152cadfaed14a6035eb49361439b8f80c7c633b5e1b185dd5dad140a4148f6d4445928e08cb8e92b205739ef75df6d49c66e4ad3cd002512cc2a8aba859b
+DIST pylama-8.0.6.tar.gz 34223 BLAKE2B 690a0a1197f6512e9511083aa079843f2ca99c9bdb5d74756531db79f7d39e8e0f60a0955b24bc7739edce0376eb79821a796978fb2365789a97628f03f240f8 SHA512 5bc75e5b2a0b141dbe2ca993d13833914980c735b84f3df766bf750909af1eeaba0d554845d8c09f0d8186ff48c8330d9ffa5b565a577ef6506f32672a2c9209
diff --git a/dev-python/pylama/pylama-8.0.6.ebuild b/dev-python/pylama/pylama-8.0.6.ebuild
new file mode 100644
index 000000000000..56e1af7e7500
--- /dev/null
+++ b/dev-python/pylama/pylama-8.0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Code audit tool for python"
+HOMEPAGE="https://github.com/klen/pylama"
+SRC_URI="https://github.com/klen/pylama/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/mccabe-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/eradicate[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/radon[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # not packaged
+ tests/test_linters.py::test_quotes
+ tests/test_linters.py::test_vulture
+)