summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-22 09:42:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-22 09:42:12 +0200
commit684dfa867feb74f0169988f33a6e1992e153561c (patch)
tree9537a3b897c64717cf30a43621d0c7b0a205d30d /dev-python/pyperclip
parentdev-python/requests-unixsocket: Remove old (diff)
downloadgentoo-684dfa867feb74f0169988f33a6e1992e153561c.tar.gz
gentoo-684dfa867feb74f0169988f33a6e1992e153561c.tar.bz2
gentoo-684dfa867feb74f0169988f33a6e1992e153561c.zip
dev-python/pyperclip: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyperclip')
-rw-r--r--dev-python/pyperclip/pyperclip-1.8.2.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/pyperclip/pyperclip-1.8.2.ebuild b/dev-python/pyperclip/pyperclip-1.8.2.ebuild
deleted file mode 100644
index e59e589a1667..000000000000
--- a/dev-python/pyperclip/pyperclip-1.8.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 virtualx
-
-DESCRIPTION="A cross-platform clipboard module for Python"
-HOMEPAGE="https://github.com/asweigart/pyperclip"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- || (
- (
- x11-misc/xsel
- sys-apps/which
- )
- (
- x11-misc/xclip
- sys-apps/which
- )
- (
- kde-plasma/plasma-workspace
- sys-apps/which
- )
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP}]
- )
-"
-# test at least one backend
-BDEPEND="
- test? (
- ${RDEPEND}
- )
-"
-
-src_prepare() {
- # stupid windows
- find -type f -exec sed -i -e 's:\r$::' {} + || die
- # klipper is hard to get working, and once we make it work,
- # it breaks most of the other backends
- # wl-copy requires wayland, not Xvfb
- sed -e 's:_executable_exists("\(klipper\|wl-copy\)"):False:' \
- -i tests/test_pyperclip.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- "${EPYTHON}" tests/test_pyperclip.py -vv ||
- die "Tests fail on ${EPYTHON}"
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}