summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-24 15:36:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-24 15:39:26 +0200
commite8c443fd1b655e74fe2a7c9896902cb670db9efb (patch)
treee698edae6f0ae842db263225ae15d25265c0a8bc /dev-python/pyphen
parentdev-python/myst-parser: Bump to 3.0.0 (diff)
downloadgentoo-e8c443fd1b655e74fe2a7c9896902cb670db9efb.tar.gz
gentoo-e8c443fd1b655e74fe2a7c9896902cb670db9efb.tar.bz2
gentoo-e8c443fd1b655e74fe2a7c9896902cb670db9efb.zip
dev-python/pyphen: Bump to 0.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyphen')
-rw-r--r--dev-python/pyphen/Manifest1
-rw-r--r--dev-python/pyphen/pyphen-0.15.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyphen/Manifest b/dev-python/pyphen/Manifest
index 7767458016e3..1315ec1ba861 100644
--- a/dev-python/pyphen/Manifest
+++ b/dev-python/pyphen/Manifest
@@ -1 +1,2 @@
DIST pyphen-0.14.0.tar.gz 1986988 BLAKE2B 3513ad1c9fbcc05318764f862a01bc4bbd6ad6a86f120ad93f8ff1d2a979984c35554db85943b5b7423f97e44ea933c64a3bf9c90aeb18629d215292466581b6 SHA512 5e242de2ecd5e951b2e1925df724013c14cea14729e8e0c132ab233c82406b37cc8d1d21cbd1edd748811fa6826a79da7a5ff9dfa859315840560cacae523e13
+DIST pyphen-0.15.0.tar.gz 2072615 BLAKE2B ce5a1d16ade5d1e894b941aa02749de5793d1b11554b232d0a475c687551843171da5c8fb31fa686af524c12693f87baf8e61a7c07e71935ca159fba42e4353f SHA512 c73ec781c92fbac1daadbf435b028a1eb6476df2bec40ceb039d394ae928ab3b3eff4f3ffaf23d847b89e766810a9dd153f6bbcb9678a9f61f65d84206042640
diff --git a/dev-python/pyphen/pyphen-0.15.0.ebuild b/dev-python/pyphen/pyphen-0.15.0.ebuild
new file mode 100644
index 000000000000..d69dde510071
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.15.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+HOMEPAGE="
+ https://github.com/Kozea/Pyphen/
+ https://pypi.org/project/pyphen/
+"
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}