summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-30 04:36:16 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-30 04:36:16 +0100
commitfc30e00a800ee1f3b21fe79a893b1e1f31ed2955 (patch)
tree7b875ac7553050ed4012fdaccc82ec836fa53ae1 /dev-python/pyphen
parentdev-python/kombu: Bump to 5.5.0_rc2 (diff)
downloadgentoo-fc30e00a800ee1f3b21fe79a893b1e1f31ed2955.tar.gz
gentoo-fc30e00a800ee1f3b21fe79a893b1e1f31ed2955.tar.bz2
gentoo-fc30e00a800ee1f3b21fe79a893b1e1f31ed2955.zip
dev-python/pyphen: Bump to 0.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyphen')
-rw-r--r--dev-python/pyphen/Manifest1
-rw-r--r--dev-python/pyphen/pyphen-0.17.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyphen/Manifest b/dev-python/pyphen/Manifest
index 1d12ab75d1c3..5f4ff32bb543 100644
--- a/dev-python/pyphen/Manifest
+++ b/dev-python/pyphen/Manifest
@@ -1 +1,2 @@
DIST pyphen-0.16.0.tar.gz 2072790 BLAKE2B c3c5b248a9532abecca09fec66594aa77313cd84f66a3fe569b39306ba937fd1f8459e5140aa2154599d805197e68806e16b51958e52f0c21792c442b7c1e62a SHA512 0469dd043578bd2f4bd12f22c10879c009be1907e34b41f5c6b4ff3d4e824a5320292308d5fd40c645a14589547b3432c7331400b2c4e64723a1e79a1ab66242
+DIST pyphen-0.17.0.tar.gz 2072773 BLAKE2B 14c7700854dfe952ff24f7d8fcd80b2287fda4e53dfd57c8cfc506162641a5f13031a0f49b3e0868e1adf050a6fb736b87b95cb5136b90e545b1328d61774a2a SHA512 2f856e9d7f404c515bc7c4c26f4a60664d1f22e08d078818d008d87809e76e4a56976169a131bb368785bd4b01b4c08b2699702afa721d498eb715eb797dc3e2
diff --git a/dev-python/pyphen/pyphen-0.17.0.ebuild b/dev-python/pyphen/pyphen-0.17.0.ebuild
new file mode 100644
index 000000000000..03102339b98f
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.17.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+HOMEPAGE="
+ https://github.com/Kozea/Pyphen/
+ https://pypi.org/project/pyphen/
+"
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}