summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:00:43 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-10 08:38:18 +0300
commitf8bdc0fedb0771d7b42181f730f2c5d8de1455d1 (patch)
tree006bbaa7654fe17c7f37e9d8e5f18d02362d573e /dev-python/pyproj
parentdev-python/PyPDF2: add 2.10.6 (diff)
downloadgentoo-f8bdc0fedb0771d7b42181f730f2c5d8de1455d1.tar.gz
gentoo-f8bdc0fedb0771d7b42181f730f2c5d8de1455d1.tar.bz2
gentoo-f8bdc0fedb0771d7b42181f730f2c5d8de1455d1.zip
dev-python/pyproj: add 3.4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest1
-rw-r--r--dev-python/pyproj/pyproj-3.4.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index 6c2536e0aef9..0eb6a9d3932e 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1 +1,2 @@
DIST pyproj-3.3.1.gh.tar.gz 238373 BLAKE2B 7996d253a35e3d64a343141179a88d2ab97e88f96447f3daf14c9f8d731099b506228c163fe460d3be30ae69c87e908879b3c0fe31eb7624c3bb8da157838337 SHA512 7175479f4ec526ada830d178bea77552d66aace4c7f6cde584aebef5fc4c6b7a46272eea2bd95f71910411c9ac8d8832d350891ffffda8a86eabb5449177a5eb
+DIST pyproj-3.4.0.gh.tar.gz 231365 BLAKE2B a62e02a33424583ffec1e1de603a0162ea187b4eb093be51b957fb720b3625c7e4b65162f1272fb4a057edfd92f8146d74c17f1ad68a3beb0ae199df8641e03b SHA512 d0e9425ea5a10ce1620c2a2b3279be786741e75ad698a2430e38237acb73e2cd7dbd16dbb4cf952f52c38810526f4528c08f9bb0795a34fdab2f39686e6914c9
diff --git a/dev-python/pyproj/pyproj-3.4.0.ebuild b/dev-python/pyproj/pyproj-3.4.0.ebuild
new file mode 100644
index 000000000000..aa7eb95785a6
--- /dev/null
+++ b/dev-python/pyproj/pyproj-3.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="
+ https://github.com/pyproj4/pyproj/
+ https://pypi.org/project/pyproj/
+"
+SRC_URI="
+ https://github.com/pyproj4/pyproj/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+RDEPEND="
+ >=sci-libs/proj-8.2.0:=
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pyproj || die
+ epytest -m "not network" test
+}