summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 05:35:26 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 05:35:48 +0200
commitc787fb174e15fa91437e0e8120ff819eefa548b1 (patch)
tree74ccca0226530a088287327b3584ba7b767f4970 /dev-python/pyproject-fmt
parentdev-python/pyproject-fmt-rust: Bump to 1.1.1 (diff)
downloadgentoo-c787fb174e15fa91437e0e8120ff819eefa548b1.tar.gz
gentoo-c787fb174e15fa91437e0e8120ff819eefa548b1.tar.bz2
gentoo-c787fb174e15fa91437e0e8120ff819eefa548b1.zip
dev-python/pyproject-fmt: Bump to 2.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-2.1.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 5ce7c2e58d4b..16de27a5879c 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1,2 +1,3 @@
DIST pyproject_fmt-1.8.0.tar.gz 16696 BLAKE2B 1614fd6da4bb7be818825138b69b826b7141ae0fcada4414daa54b1c883ec3bbdbe95377155869d0c393b1b9646b69ebb009fe47f1c530b1f1c9f02c8ba8f57d SHA512 0731ffbe514cf8788bf1cfcca506591fefce3b98b1c6d014a8e17825ab6c73edc4ad8e7214cd8f6fc9124ed2ff362d03b328d47e96a6246165b4dd9fdd68299f
DIST pyproject_fmt-2.1.0.tar.gz 9012 BLAKE2B 5ddc95d9f5ef322f1895772d63a3d6a800172d57655f795d74a077628020ab54ee1a4ef52b3a317504567ce2a13b4c6cd229f7ee05dbcc5fecabb0762679f12e SHA512 00a9541c61ca1924a78a48736962df39e055cf61cd2a312dc0fd2c7efb247d504f7e747912d328e689de25049c944cc2b422dc6c74c1c1e910b6294bd2306944
+DIST pyproject_fmt-2.1.1.tar.gz 9015 BLAKE2B 40203bcae46203f4b0edba02290741788b5ea382595e0da4717a72a632e78bb4ce7d8ea3ae1d91129a9f51e2116b02ce65990419f878a4676aa152e4eb75fd67 SHA512 4ccb98d8a8fa6d1ee8f63a6e6fdfeab4411da267ec85da957fab92f593dfaf142daebd1cd9a398afe0ec18c135c365733d529204f042a57da7be9622f09dd7d1
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-2.1.1.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-2.1.1.ebuild
new file mode 100644
index 000000000000..eebff30a0ae0
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-2.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ ~dev-python/pyproject-fmt-rust-1.1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest