summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2023-01-25 08:31:57 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-05 11:12:52 +0200
commit662b555ca72aca5e749a63fd9c992c48781bc78f (patch)
treeaf0fab6f8f69577fb8299dd19a9a9c27c9397409 /dev-python/pyroute2
parentdev-libs/libmemcached-awesome: drop old (diff)
downloadgentoo-662b555ca72aca5e749a63fd9c992c48781bc78f.tar.gz
gentoo-662b555ca72aca5e749a63fd9c992c48781bc78f.tar.bz2
gentoo-662b555ca72aca5e749a63fd9c992c48781bc78f.zip
dev-python/pyroute2: add 0.7.4
Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/29256 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pyroute2')
-rw-r--r--dev-python/pyroute2/Manifest1
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyroute2/Manifest b/dev-python/pyroute2/Manifest
index 9c10beaf8629..96688a7af7ab 100644
--- a/dev-python/pyroute2/Manifest
+++ b/dev-python/pyroute2/Manifest
@@ -1 +1,2 @@
DIST pyroute2-0.7.3.gh.tar.gz 484152 BLAKE2B 4f0cd0fc000c7bd3baffaa2ed25468bc28806fef2f9bc96e39606afe46e616d85865f497df6d1e3e4b2e5e3956b5fca22af273140bbb38954c6f0c0f86c386a6 SHA512 c8aeddaeaa014bcf8c4b831cb5b4080db5c99b582f3999fdbdd840b9448e032fbbf64ce5707ebc0795765138d8e89cde830efb2469c827ed8d4e63dd1beafe62
+DIST pyroute2-0.7.4.gh.tar.gz 493544 BLAKE2B 57a5ff075508b185808826d823b7369a35b21a9a664e507b901ef82540645e1e621fba8fe33212fbd20595eaeaa91db965cd76398c0daed18fc43c8edee029f9 SHA512 9ec4f8ec8f95d36d0cf780cf06ba6cf70f1c8d96647b2f3f8f059277a32ad55d15b5411fde815a71824e4d10cf8efbece47a7c88df9c76eaa84f61f8f7c8ff85
diff --git a/dev-python/pyroute2/pyroute2-0.7.4.ebuild b/dev-python/pyroute2/pyroute2-0.7.4.ebuild
new file mode 100644
index 000000000000..094f6662512b
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="https://github.com/svinota/pyroute2"
+
+SRC_URI="
+ https://github.com/svinota/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+# tests need root access
+RESTRICT="test"