summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-19 13:25:09 +0000
committerSam James <sam@gentoo.org>2021-11-19 13:32:27 +0000
commit9b7fa83bbf0fde3d0fa23ea0ecd521c62a71ddb1 (patch)
treecd25988dac2de800a01b40ec59375f163136c250 /dev-python/pytables
parentdev-python/pytables: depend on older hdf5 (diff)
downloadgentoo-9b7fa83bbf0fde3d0fa23ea0ecd521c62a71ddb1.tar.gz
gentoo-9b7fa83bbf0fde3d0fa23ea0ecd521c62a71ddb1.tar.bz2
gentoo-9b7fa83bbf0fde3d0fa23ea0ecd521c62a71ddb1.zip
dev-python/pytables: disable use of bundled libraries
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/pytables-3.6.1-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pytables/pytables-3.6.1-r1.ebuild b/dev-python/pytables/pytables-3.6.1-r1.ebuild
index ffa7d9a37680..594f1e68b4fc 100644
--- a/dev-python/pytables/pytables-3.6.1-r1.ebuild
+++ b/dev-python/pytables/pytables-3.6.1-r1.ebuild
@@ -37,6 +37,7 @@ RDEPEND="${DEPEND}
dev-python/six[${PYTHON_USEDEP}]"
BDEPEND="
>=dev-python/cython-0.21[${PYTHON_USEDEP}]
+ virtual/pkgconfig
test? (
dev-python/mock[${PYTHON_USEDEP}]
${RDEPEND}
@@ -51,7 +52,10 @@ PATCHES=(
)
python_prepare_all() {
- export HDF5_DIR="${EPREFIX}"/usr
+ export {BLOSC,BZIP2,LZO,HDF5}_DIR="${ESYSROOT}"/usr
+ export PYTABLES_NO_EMBEDDED_LIBS=1
+ export USE_PKGCONFIG=TRUE
+
rm tables/*.c || die
sed -e "s:/usr:${EPREFIX}/usr:g" \
-i setup.py || die