summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-24 08:25:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-24 08:41:23 +0200
commit58b93b807b4f9b9307c7f11e94f0deae9916e65a (patch)
tree3e0253ca5ba6babfcaa4999566cff243e5178284 /dev-python/pytest-asyncio
parentdev-python/aiohttp: Remove old (diff)
downloadgentoo-58b93b807b4f9b9307c7f11e94f0deae9916e65a.tar.gz
gentoo-58b93b807b4f9b9307c7f11e94f0deae9916e65a.tar.bz2
gentoo-58b93b807b4f9b9307c7f11e94f0deae9916e65a.zip
dev-python/pytest-asyncio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.24.0_alpha0.ebuild51
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.24.0_alpha1.ebuild44
3 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 891c8d8cdce1..81dbaa127c28 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,4 +1,2 @@
DIST pytest_asyncio-0.23.8.tar.gz 46920 BLAKE2B 6b7a66e6ef28f2c7a874a115e0346b3803051df5d57e5b8ba35480982231a804adfbe8a4a2c605847730ea940fafe9df2aa94f5081b43aa753b64c3e2ea027a5 SHA512 68f23458c5f22bdb75a6a0a12f185b1f22c5231c0cdcd84806781419f5c866844e851398d771c5932af4a42b5dfdcce6624181f2c0d2f70187bb5feed0ba7c97
DIST pytest_asyncio-0.24.0.tar.gz 49855 BLAKE2B 55813b655252f2c1fbe1658a0a2d739bb03a56794297dde9cf598b8200c0d3aa7437af7a241a821eff47ffe57841142adb93c6434c920cbd1d26b33a8ac8fe96 SHA512 abf2442afb9f5933b223e920c0b107d5781350f2a9c2e58ca141494a4f391acf97f2e377db1fc67b5213031bf371f222dc9c4718ff3c6b5985f5e49913f03cb7
-DIST pytest_asyncio-0.24.0a0.tar.gz 49299 BLAKE2B 2bc9f0a85169db463f344ed1f42dd954599c6e50a3fa3d7bf95bddb3eb162c4ddf454f512d7b1577e0d394174f52dd63664e4eec32a6106a7c2779cf955cb79a SHA512 109ff55bb3f742a246463ed650a6568833e70cd0b4ed30507efb62cf3c9eb5aa9caed960b3b1c9b92c1cb30025436e9e98e33135243a5763b2614632cbae5c8e
-DIST pytest_asyncio-0.24.0a1.tar.gz 49212 BLAKE2B d65eb2587ef865d62a8f3469165da58ca9db0ffe98b4ba02b3be36811f635aeac01457b0931fda4653ec7e8634d3dfe70e7e3b5a40be5ae7018bb8f7317fef95 SHA512 33a84c17a853a5b3c4153a178e70fa04ce3494d6f316f0a141b4d945c5052c6c336f55f7ca691423ce448d1e7535d84bc69d939cfc4544076e704a7e5b4509f7
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.24.0_alpha0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.24.0_alpha0.ebuild
deleted file mode 100644
index ccbee1a2f1c6..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.24.0_alpha0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
- tests/modes/test_legacy_mode.py
- tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
- tests/test_pytest_min_version_warning.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
-
- # TODO
- tests/test_is_async_test.py::test_returns_false_for_unmarked_coroutine_item_in_strict_mode
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
- epytest
-}
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.24.0_alpha1.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.24.0_alpha1.ebuild
deleted file mode 100644
index ef22178cd3b7..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.24.0_alpha1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-8.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
- tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
- epytest
-}