summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-25 14:54:02 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-25 14:58:28 +0100
commite99625527a5d0f17b1529b683baee28640a03ea7 (patch)
tree97c0fee0512e9639a0af824575e0cee27b143071 /dev-python/pytest-asyncio
parentdev-python/jaraco-text: Remove old (diff)
downloadgentoo-e99625527a5d0f17b1529b683baee28640a03ea7.tar.gz
gentoo-e99625527a5d0f17b1529b683baee28640a03ea7.tar.bz2
gentoo-e99625527a5d0f17b1529b683baee28640a03ea7.zip
dev-python/pytest-asyncio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest1
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.19.0.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index eb83221d09a8..58cd6a091b2a 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,2 @@
-DIST pytest-asyncio-0.19.0.gh.tar.gz 25754 BLAKE2B ee1e028021d7adaeef77e9dc9c1cc0d1a8fe5ee91777b2774d8f175e7520f7f1ae6d058d758964a052d2fc02d369a9dcb522edf8271b54b9b724555222592e29 SHA512 7be87e6edd28496713ae5cca396fed67d372f2882dd573a8b72a84ebf6d262060cda9372bcde601130c42fc27faf15cf292cd820995ea93a324c209f203e823f
DIST pytest-asyncio-0.20.1.gh.tar.gz 25425 BLAKE2B 90ab8ebdb854b78b0e910b26ffeab4841f0e6dc122bd8c12fa908a59e125473770bac553a8046be37679222016c204c83d9e01db27f6eca765fb3d9b6461d090 SHA512 994b942bc6452bd3972070d1eee3d88c6680a818ad38d6ed5ffa1faba51473227c838eaf24316c74479e7bb9faaf7fd3cbd1e5a07c2611f0e2eaffe369f75d95
DIST pytest-asyncio-0.20.2.gh.tar.gz 25876 BLAKE2B 75f948b804cb8945ec6153a5386ec4e2c5e95757c012acb04f9dcc877b109f0af1f9093a242c6d38196014c8da01fe459687d37fd4cb2fbeed2705936a9fba15 SHA512 5d8b4965cea14dec2a2c7f21f6bb1bad6693b93f07b9dab5c880107a944942bd2c3ef38adc0e17b309222a53afa7504f827baf42201c2a0282a266118e3f7eb7
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.19.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.19.0.ebuild
deleted file mode 100644
index 7ae9ead863fc..000000000000
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.19.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for testing asyncio code with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-asyncio/
- https://pypi.org/project/pytest-asyncio/
-"
-SRC_URI="
- https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-EPYTEST_DESELECT=(
- # rely on precise warning counts
- tests/modes/test_legacy_mode.py
- tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
-)
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin,flaky.flaky_pytest_plugin
- epytest
-}