summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-21 19:12:16 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-21 19:15:17 -0800
commitacaca9f5de2b346664ea6715e5b8724f5c545093 (patch)
treee37e5ceb38a8d5bd6bbd161b45deab35e58353e8 /dev-python/pytest-cov
parentdev-python/twine: Version bump to 3.0.0 (diff)
downloadgentoo-acaca9f5de2b346664ea6715e5b8724f5c545093.tar.gz
gentoo-acaca9f5de2b346664ea6715e5b8724f5c545093.tar.bz2
gentoo-acaca9f5de2b346664ea6715e5b8724f5c545093.zip
dev-python/pytest-cov: Version bump to 2.8.1
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch20
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.8.1.ebuild67
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index a6c3db6454a9..80209ad865e4 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,2 +1,3 @@
DIST pytest-cov-2.3.1.tar.gz 35378 BLAKE2B 758846db0b06ef9534823d3458ad6211b0cfc14b551a6e1737573a5c1c5bb59c23b26d3448ff8a67d65a4293ce75dd8c79d4916d3d9a7db5021db6b907152230 SHA512 79770beb53fbb43b5d68311c2efd0accbfd890ab6dad299da8c1c0b3d26b54d984807313b1507900cda7004bfb50fedc0bd4341cfcfce47849a4f24fc8184f11
DIST pytest-cov-2.6.1.tar.gz 35307 BLAKE2B 11974ff70ed5609d7db3c4c35f5b528b0ec36b48cfaf06974a090127706e0964841347592ac3f1e086f46800857ee10c05404045b6a4b467ffa278c2ee1e1957 SHA512 2dfd16e013d8bfbe5d14990f419291b651dd11560328a7e59b5449016d51b17f84d4ee3866fda866c3530389d206b1c4c67c84b23f097281c3963ffd19ea8caa
+DIST pytest-cov-2.8.1.tar.gz 47661 BLAKE2B 590fd50b69d01a71b20982d8cdbed0698ebe24c290d791bb44c96aa1aaaf77cf1f379d565eb775864c6945facf6d271115236cb44b95e4a4c9bb7cc6fd591acf SHA512 769a17c2095dbe990df148a0105c9e3dc88ac2265ac77ac31448dab6abf6d8cc0d54f5c6ff01fd708bd38700bfea93f57d3bb702bd9bb0a708257d094b2376ec
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch
new file mode 100644
index 000000000000..660db5e59431
--- /dev/null
+++ b/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch
@@ -0,0 +1,20 @@
+diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
+index e79e9aa..e5ef2c1 100644
+--- a/tests/test_pytest_cov.py
++++ b/tests/test_pytest_cov.py
+@@ -820,6 +820,7 @@ parallel = true
+ assert result.ret == 0
+
+
++@pytest.mark.skip(reason="test is broken")
+ def test_central_subprocess_change_cwd_with_pythonpath(testdir, monkeypatch):
+ stuff = testdir.mkdir('stuff')
+ parent_script = stuff.join('parent_script.py')
+@@ -951,6 +952,7 @@ def test_invalid_coverage_source(testdir):
+ assert not matching_lines
+
+
++@pytest.mark.skip(reason="test is broken")
+ @pytest.mark.skipif("'dev' in pytest.__version__")
+ @pytest.mark.skipif('sys.platform == "win32" and platform.python_implementation() == "PyPy"')
+ def test_dist_missing_data(testdir):
diff --git a/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
new file mode 100644
index 000000000000..10e7f1f4e01c
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for coverage reporting"
+HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ doc? (
+ $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep 'dev-python/sphinx-py3doc-enhanced-theme[${PYTHON_USEDEP}]')
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ # Bug 597708
+ "${FILESDIR}/${PN}-2.8.1-disable-broken-tests.patch"
+)
+
+python_check_deps() {
+ use doc || return 0
+ local dep
+ for dep in dev-python/sphinx dev-python/sphinx-py3doc-enhanced-theme; do
+ has_version ${dep}[${PYTHON_USEDEP}] || return ${?}
+ done
+}
+
+python_compile_all() {
+ use doc && sphinx-build -b html docs _build/html
+}
+
+python_test() {
+ distutils_install_for_testing
+ PYTHONPATH="${S}/tests:${BUILD_DIR}/lib:${PYTHONPATH}" \
+ PYTEST_PLUGINS=${PN/-/_} \
+ pytest -vv || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( _build/html/. )
+ distutils-r1_python_install_all
+}