summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 16:34:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 16:36:16 +0200
commit71ff568387b0d7e4c7502791143f110cb6de8311 (patch)
tree52ffa33227f28c5a91887cff5a5b9bd4acafd81d /dev-python/pytest-mock
parentdev-python/pygments: Remove old (diff)
downloadgentoo-71ff568387b0d7e4c7502791143f110cb6de8311.tar.gz
gentoo-71ff568387b0d7e4c7502791143f110cb6de8311.tar.bz2
gentoo-71ff568387b0d7e4c7502791143f110cb6de8311.zip
dev-python/pytest-mock: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/pytest-mock-2.0.0.ebuild42
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 9a36888b97b4..c44588580b2d 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,2 +1 @@
-DIST pytest-mock-2.0.0.tar.gz 24665 BLAKE2B 31a3464e8bff5a2109716e95492ce1d59f2555769e69cccf4012bc268f88c5eeca99924006bdc78cc5e20cf227860d845bead9656aba1c081da58effb38ea100 SHA512 8bd7f634afebeae628470270c81f0198647bf8cd5b0fac438891d881d9823e40e814d598670bb9c9722b864990958e69d385c7c6a6e2adc81d2adcb303fbe0b0
DIST pytest-mock-3.3.1.tar.gz 27551 BLAKE2B 9e3602b988c0e27caa295d42d7400cbe7e3e30392511e662fa6ec16ec9fa4ef776d3e64b63b0345d1b520f753c6776103f507f91f0bad022544bfccc510b7e6b SHA512 ffd53974f82f725cf3bdbe750c1deb568ad1a12a67532eca93ff28d80b1cbcd8ebf709985f5473717c9d54345b251c1627c0567821e9e8b9e102db5c16cf7421
diff --git a/dev-python/pytest-mock/pytest-mock-2.0.0.ebuild b/dev-python/pytest-mock/pytest-mock-2.0.0.ebuild
deleted file mode 100644
index 08eb52a89381..000000000000
--- a/dev-python/pytest-mock/pytest-mock-2.0.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-2[${PYTHON_USEDEP}]' -2)"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/pytest-mock-2.0.0-warnings.patch
-)
-
-src_prepare() {
- if has_version dev-python/mock; then
- # test fails when standalone mock is installed
- sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i tests/test_pytest_mock.py || die
- fi
- distutils-r1_src_prepare
-}
-
-python_test() {
- distutils_install_for_testing
- pytest --assert=plain -vv || die "Tests fail with ${EPYTHON}"
-}