summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-30 18:15:43 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-30 18:23:21 +0100
commit2883c4cda370663d9f126c6b87177740110bb394 (patch)
treee77b2dc3c41df30a39f72d259d0707e6a8e4703e /dev-python/pytest-services
parentdev-python/pytest-xprocess: Bump to 0.16.0 (diff)
downloadgentoo-2883c4cda370663d9f126c6b87177740110bb394.tar.gz
gentoo-2883c4cda370663d9f126c6b87177740110bb394.tar.bz2
gentoo-2883c4cda370663d9f126c6b87177740110bb394.zip
dev-python/pytest-services: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-services')
-rw-r--r--dev-python/pytest-services/Manifest1
-rw-r--r--dev-python/pytest-services/pytest-services-2.2.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pytest-services/Manifest b/dev-python/pytest-services/Manifest
index 33203f5efd3e..aa7af4dde448 100644
--- a/dev-python/pytest-services/Manifest
+++ b/dev-python/pytest-services/Manifest
@@ -1,2 +1,3 @@
DIST pytest-services-2.1.0.tar.gz 20552 BLAKE2B 6359c419591efed553e095e267c24f78f36b152f0eefe21d46742f7c15f05e92a9e86891f99762a3716fef5284b00d07d8d6eb825008dbbbf07e36dc62a7a6b4 SHA512 54a487546a2af7996acdbcd63bfc01626832aa41683617cdd345453cf6518afdf03cb8c2465e1f5d28c88b2cc801ffb0d9d4440582865f899e21fe42ab431ebc
DIST pytest-services-2.2.0.tar.gz 20995 BLAKE2B a65455d89190d6b63854df7509124c8056c962640972f67210e3b3dbf2d669708e4edb124077cd32e7fe429e884372f4248396377b5d4879d9f7313c3ef7df46 SHA512 48430d6c107626a4e13a8eb16cf5cc3b2068e34869b8a4e3e615fd7a20f3644a028c911211f3de885ffd942cafd3946c313e76ddcf6199bedc9731f7b88c843a
+DIST pytest-services-2.2.1.tar.gz 21303 BLAKE2B 6f4b66b713ca4976eae61bf516bfecf13b8d6f56e03ae772ba9465e7c4c52b8d5ffa713b9441c73538a0b05665da7b7aa53d5f5da1626c6c208edf1c8239b1b1 SHA512 95d70431a7c3fa3b1602e6ad0e72975cecf5f0464e1bbc21d5b4eee6aefee52794c7b1d8dacf0681cc4cbb5ae7910075a7d0b3859647cc55298a2792489c4bfb
diff --git a/dev-python/pytest-services/pytest-services-2.2.1.ebuild b/dev-python/pytest-services/pytest-services-2.2.1.ebuild
new file mode 100644
index 000000000000..a10297b8270e
--- /dev/null
+++ b/dev-python/pytest-services/pytest-services-2.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Collection of fixtures and utility functions to run service processes for pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-services"
+SRC_URI="https://github.com/pytest-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/zc-lockfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ net-misc/memcached
+ !dev-python/pytest-salt
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/pytest-services-2.0.1-no-mysql.patch"
+ "${FILESDIR}/pytest-services-2.0.1-lockdir.patch"
+)
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ find "${D}" -name '*.pth' -delete || die
+}