summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-11 04:36:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-11 05:14:25 +0200
commitdef0621a009be28b95b5b268f7873a823ded8f05 (patch)
tree57e1b42a0c0477178c3fcbe174c47e2ae3908408 /dev-python/pytest-sugar
parentdev-python/pygments: Bump to 2.15.0 (diff)
downloadgentoo-def0621a009be28b95b5b268f7873a823ded8f05.tar.gz
gentoo-def0621a009be28b95b5b268f7873a823ded8f05.tar.bz2
gentoo-def0621a009be28b95b5b268f7873a823ded8f05.zip
dev-python/pytest-sugar: Bump to 0.9.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-sugar')
-rw-r--r--dev-python/pytest-sugar/Manifest1
-rw-r--r--dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-sugar/Manifest b/dev-python/pytest-sugar/Manifest
index 4c7426258b8f..a18bf5832b80 100644
--- a/dev-python/pytest-sugar/Manifest
+++ b/dev-python/pytest-sugar/Manifest
@@ -1 +1,2 @@
DIST pytest-sugar-0.9.6.tar.gz 13702 BLAKE2B 72a48d501ba5bd597ec2561817179cd50213d1de80a3281823033d9d1a1c62f37367353885d805a6e212380ddaa934b1e0887814742e26cd1b809b4ef629cf19 SHA512 955e28478854c6751e7470b49f130bce2904c1f74d46caa2a6e212c132e3f1f0565f2f31ac360a32d2d9c4999f4dcdd19e7373508660bfd7da530981aef9cd62
+DIST pytest-sugar-0.9.7.tar.gz 14874 BLAKE2B eb65d3261be10897b98f29704a8cd32102a91f7d3023651a6fc5c69e7d4f77c9ade1b3ca808047d0813503ceb416490126402f4751ac93fbdaadf9ddd1ef13c7 SHA512 7ab1a4f91bd252452ffd5b4fa636a1dffd4ffa5a19c839f2d00d0c69b885216144bb25e1a666bebb17be8112a397adfe04d5caa215edc98f64c20fefd43334cf
diff --git a/dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild b/dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild
new file mode 100644
index 000000000000..2c347f622f6c
--- /dev/null
+++ b/dev-python/pytest-sugar/pytest-sugar-0.9.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plugin that changes the default look and feel of pytest"
+HOMEPAGE="
+ https://github.com/Teemu/pytest-sugar/
+ https://pypi.org/project/pytest-sugar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.2.0[${PYTHON_USEDEP}]
+ >=dev-python/termcolor-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest