summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-03 07:31:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-03 07:51:22 -0400
commit1c8c24dd9ea85d8c0a0dfdcdd0fcc7862cdc1258 (patch)
treeecd0faa3420ef2ba1e47b03f39136588ff486b99 /dev-python/pytest-xvfb
parentmedia-libs/vips: enable py3.13 (diff)
downloadgentoo-1c8c24dd9ea85d8c0a0dfdcdd0fcc7862cdc1258.tar.gz
gentoo-1c8c24dd9ea85d8c0a0dfdcdd0fcc7862cdc1258.tar.bz2
gentoo-1c8c24dd9ea85d8c0a0dfdcdd0fcc7862cdc1258.zip
dev-python/pytest-xvfb: enable py3.13
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/pytest-xvfb')
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
index 4f09bfae28da..d343380ff98b 100644
--- a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
+++ b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
@@ -1,20 +1,16 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE="tk"
-
inherit distutils-r1 pypi
DESCRIPTION="Pytest plugin to run Xvfb for tests"
-HOMEPAGE="
- https://github.com/The-Compiler/pytest-xvfb/
- https://pypi.org/project/pytest-xvfb/
-"
+HOMEPAGE="https://github.com/The-Compiler/pytest-xvfb/"
LICENSE="MIT"
SLOT="0"
@@ -31,5 +27,6 @@ distutils_enable_tests pytest
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_xvfb
+
epytest --runpytest=subprocess
}