summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-08 16:04:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 18:43:45 +0200
commit238bd01c800450289ebf3ac52b5956c386530104 (patch)
tree0246d9658550cc9e37cacb0a9431993982dfa0fa /dev-python/python-poppler-qt5
parentdistutils-r1.eclass: Introduce sipbuild backend support (diff)
downloadgentoo-238bd01c800450289ebf3ac52b5956c386530104.tar.gz
gentoo-238bd01c800450289ebf3ac52b5956c386530104.tar.bz2
gentoo-238bd01c800450289ebf3ac52b5956c386530104.zip
dev-python/python-poppler-qt5: Bump to 21.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-poppler-qt5')
-rw-r--r--dev-python/python-poppler-qt5/Manifest1
-rw-r--r--dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-poppler-qt5/Manifest b/dev-python/python-poppler-qt5/Manifest
index 1139449118c1..ac4ae3ac9c84 100644
--- a/dev-python/python-poppler-qt5/Manifest
+++ b/dev-python/python-poppler-qt5/Manifest
@@ -1 +1,2 @@
DIST python-poppler-qt5-0.75.0.tar.gz 23281 BLAKE2B 06b2b0899d2a3cfc84e623b98cc3379aa45ac9ca9267f25168cce04f2ed761fd897043376fda3386b2daff2b46850b24782cafd6aabb13a8e7d6f3920b55a02c SHA512 2f03036a2eaeb8e28875f19a813ff85a91c1e9a94301bdb736ecc50e7ececb4de2622728e6fecbf64e114435529f82b6afd23d772e2d3910ae03d5d2b5da3205
+DIST python-poppler-qt5-21.3.0.tar.gz 25641 BLAKE2B 5937f1ddc1493bb1ef1d98b91dd8ccec4bd8c835956d84c8d7ce7a1cedcbe16854861e1f13825812e0f74c335020f0d74aad2d2bbc7a5780c6eb3ac77437f13b SHA512 cc942a860c2c999ff04fb0468b1556b0e23e7aa19a0185a39c5e903e717dca64bcbd51b8fe34b6885bd789cbf5cc1080c2ca1dcee30b3e69fa1721618e8db278
diff --git a/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild b/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
new file mode 100644
index 000000000000..11ca6622f42e
--- /dev/null
+++ b/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=sip
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing qmake-utils
+
+DESCRIPTION="Python binding for libpoppler-qt5"
+HOMEPAGE="https://github.com/frescobaldi/python-poppler-qt5"
+SRC_URI="https://github.com/frescobaldi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[qt5]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ DISTUTILS_ARGS=(
+ --jobs="$(makeopts_jobs)"
+ --qmake="$(qt5_get_bindir)"/qmake
+ --qmake-setting="$(qt5_get_qmake_args)"
+ --verbose
+ )
+}