summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-29 07:26:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-29 08:12:57 +0100
commit2862f3eb0c4f0b8470cb86d6da2713669ec68d24 (patch)
tree4cccb2ceb3c5c087ecba419fccd942601c615f78 /dev-python/python-slugify
parentdev-python/whatthepatch: Bump to 1.0.4 (diff)
downloadgentoo-2862f3eb0c4f0b8470cb86d6da2713669ec68d24.tar.gz
gentoo-2862f3eb0c4f0b8470cb86d6da2713669ec68d24.tar.bz2
gentoo-2862f3eb0c4f0b8470cb86d6da2713669ec68d24.zip
dev-python/python-slugify: Bump to 8.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest1
-rw-r--r--dev-python/python-slugify/python-slugify-8.0.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 2290c21d4f46..73786d315f9d 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1 +1,2 @@
DIST python-slugify-7.0.0.gh.tar.gz 13257 BLAKE2B 6d50fd25ac89caed3a970f4cce786d9b61de68386fc183659c0d884877edc934e121ad07316259af08deb61a30ac33f0076a90b2d5a650dfb113e6b6416addfe SHA512 c22743a28ffb273546541eaf59d2a7beb9070a7f81e504acaf73d220c2be83a87d02012b5841076539ba6bae5778dd47309ee7ceef9f8479c993dda6b3e09837
+DIST python-slugify-8.0.0.gh.tar.gz 13322 BLAKE2B 146b04d75aa1aefa0a28824c2c3dd3f323ddfd49dbaafc82a9d9401de8fbdea25793c833e17b4a04cfc646fa371a0a10c40011be870fef573a8f0f8977671d26 SHA512 24d9309873c5bd625a9301b3a7844c7a1f3d2adb5faad9e49563446e33ab08f3d984c6692fb36885fdc363bee8c86252092ea0fc8f1b70152cff3365db37fd82
diff --git a/dev-python/python-slugify/python-slugify-8.0.0.ebuild b/dev-python/python-slugify/python-slugify-8.0.0.ebuild
new file mode 100644
index 000000000000..e80db8044cf6
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-8.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/text-unidecode[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest