summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-16 07:28:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-16 07:39:11 +0200
commit8772ee1ec62e14307c58a6313aa8498ef95f4d69 (patch)
treea80178dd13ce13f0ca4357f11b4a305485bb9f44 /dev-python/pytools
parentdev-ruby/rspec-rails: add 5.0.2 (diff)
downloadgentoo-8772ee1ec62e14307c58a6313aa8498ef95f4d69.tar.gz
gentoo-8772ee1ec62e14307c58a6313aa8498ef95f4d69.tar.bz2
gentoo-8772ee1ec62e14307c58a6313aa8498ef95f4d69.zip
dev-python/pytools: Bump to 2021.2.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytools')
-rw-r--r--dev-python/pytools/Manifest1
-rw-r--r--dev-python/pytools/pytools-2021.2.8.ebuild24
-rw-r--r--dev-python/pytools/pytools-9999.ebuild11
3 files changed, 30 insertions, 6 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index 3170a438766c..70a20ed250a9 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1 +1,2 @@
DIST pytools-2021.2.7.tar.gz 63673 BLAKE2B 0d64aea8c87bf7d8f6f0fb432545fc20589aadf8cee41fdc9096a1e59e1ec4588812b803cffcbf8cc92bab4e18d5ea4422beeddc9408051af11e06b04d8e7a6a SHA512 284fbdb638d40247e330c254567f594f723cad467a504bb31852c0ec5cbbb0648d9596c65e9839975bbe3a52556896440c25da5d2171aaed7c26ba38db6a4426
+DIST pytools-2021.2.8.tar.gz 63381 BLAKE2B 975a611c0ee7b013facf9754926d52e66184d69b9bbbe3ddafd252d0c0bd093c11cb91140879e2660b7e2a4f2291b58f728b2e19add2e205653df59a9f2b7be2 SHA512 9dde96889c3505f5cf4eb06c3174b889ed8ecc964ac95d8cbf36ad500ab23470c5ee46b8f96bc4fa5d2dc710d3603680643a61e10bac4da8305d92b1e3ebd0d8
diff --git a/dev-python/pytools/pytools-2021.2.8.ebuild b/dev-python/pytools/pytools-2021.2.8.ebuild
new file mode 100644
index 000000000000..5400173d9dde
--- /dev/null
+++ b/dev-python/pytools/pytools-2021.2.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="https://mathema.tician.de/software/pytools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pytools/pytools-9999.ebuild b/dev-python/pytools/pytools-9999.ebuild
index 17a4d2a89990..2bd2c25235ec 100644
--- a/dev-python/pytools/pytools-9999.ebuild
+++ b/dev-python/pytools/pytools-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE='sqlite'
-DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1 git-r3
@@ -16,9 +15,9 @@ EGIT_REPO_URI="https://github.com/inducer/pytools"
LICENSE="MIT"
SLOT="0"
-RDEPEND=">=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+RDEPEND="
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
>=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.8.0[${PYTHON_USEDEP}]"
+"
distutils_enable_tests pytest