summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-10-28 22:54:53 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-10-28 22:55:32 +0700
commit49838c757565b8e66b7d13b0bca5cb0498f501c4 (patch)
tree5c4cf55527ccb072ee1001de3fa478bffeaf6d0f /dev-python/pyxdg/pyxdg-0.28-r1.ebuild
parentpackage.mask: mask app-editors/fte for removal (diff)
downloadgentoo-49838c757565b8e66b7d13b0bca5cb0498f501c4.tar.gz
gentoo-49838c757565b8e66b7d13b0bca5cb0498f501c4.tar.bz2
gentoo-49838c757565b8e66b7d13b0bca5cb0498f501c4.zip
dev-python/pyxdg: add python3_12
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/pyxdg/pyxdg-0.28-r1.ebuild')
-rw-r--r--dev-python/pyxdg/pyxdg-0.28-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyxdg/pyxdg-0.28-r1.ebuild b/dev-python/pyxdg/pyxdg-0.28-r1.ebuild
new file mode 100644
index 000000000000..deb254a6cf7c
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.28-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_P="${PN}-rel-${PV}"
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="
+ https://freedesktop.org/wiki/Software/pyxdg/
+ https://pypi.org/project/pyxdg/
+"
+SRC_URI="
+ https://github.com/takluyver/pyxdg/archive/rel-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-py3.12.patch )
+
+distutils_enable_tests pytest