summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-02 09:30:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-02 09:30:51 +0100
commitd4dde200b6c19614b50ec17bde9a4defcfd12f9a (patch)
treeac69cb5b2cb1de649747864ea5bcda71f9483418 /dev-python/pyxdg
parentdev-python/hypothesis: Remove old (diff)
downloadgentoo-d4dde200b6c19614b50ec17bde9a4defcfd12f9a.tar.gz
gentoo-d4dde200b6c19614b50ec17bde9a4defcfd12f9a.tar.bz2
gentoo-d4dde200b6c19614b50ec17bde9a4defcfd12f9a.zip
dev-python/pyxdg: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyxdg')
-rw-r--r--dev-python/pyxdg/Manifest1
-rw-r--r--dev-python/pyxdg/files/pyxdg-0.26-python384.patch58
-rw-r--r--dev-python/pyxdg/pyxdg-0.26-r2.ebuild27
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/pyxdg/Manifest b/dev-python/pyxdg/Manifest
index 58dc0a82e5ba..f50d9b96884d 100644
--- a/dev-python/pyxdg/Manifest
+++ b/dev-python/pyxdg/Manifest
@@ -1,2 +1 @@
-DIST pyxdg-rel-0.26.tar.gz 68435 BLAKE2B a95948db17da9909554e82c0ccf590c3f94ec26d1e34d5ba335868233a649368c08ef30cc19e878310ef038e5bdb6d18cd0e15e9413d9c54b70931f25844ee8c SHA512 0c11bccb74b8c0d98f3c63c318d35d08e1c3bbea128bf7b82792e1bdc0a60c8c4d6414b0612b19296cfb48f7951dfc6dd55ac8d23238e370e7faf6c4f64d1fb6
DIST pyxdg-rel-0.27.tar.gz 75385 BLAKE2B 44c275ad7f698ffea6963f67bdce46e4faed5c7ae7f6a5aeb03f31dba6358c07263ea826458982cc4f88c0e163c2732f5b498a8d38b5881433e5321cfb181ac6 SHA512 fa3b046ce741574a6c71ef9d1e57752f6c9775431110f6ea38dc851780b5e1f9033eabeb15c67c91bc9bef68bf8f545a25ef856c60e16ab2c4fcbbb053d8341e
diff --git a/dev-python/pyxdg/files/pyxdg-0.26-python384.patch b/dev-python/pyxdg/files/pyxdg-0.26-python384.patch
deleted file mode 100644
index def4a835f036..000000000000
--- a/dev-python/pyxdg/files/pyxdg-0.26-python384.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 9b913229ace838958e51a16cabc41905a2460f7b Mon Sep 17 00:00:00 2001
-From: Conrad Kostecki <conrad@kostecki.com>
-Date: Tue, 25 Aug 2020 00:24:53 +0200
-Subject: [PATCH] Fix compatibility with >=python-3.8.4
-
-Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
----
- xdg/Menu.py | 16 ++++++++++++++--
- 1 file changed, 14 insertions(+), 2 deletions(-)
-
-diff --git a/xdg/Menu.py b/xdg/Menu.py
-index 1d03cad..ee406bd 100644
---- a/xdg/Menu.py
-+++ b/xdg/Menu.py
-@@ -21,6 +21,7 @@ def print_menu(menu, tab=0):
- import locale
- import subprocess
- import ast
-+import sys
- try:
- import xml.etree.cElementTree as etree
- except ImportError:
-@@ -35,6 +36,17 @@ def print_menu(menu, tab=0):
- import xdg.Config
-
-
-+def _ast_const(name):
-+ if sys.version_info >= (3, 4):
-+ name = ast.literal_eval(name)
-+ if sys.version_info >= (3, 8):
-+ return ast.Constant(name)
-+ else:
-+ return ast.NameConstant(name)
-+ else:
-+ return ast.Name(id=name, ctx=ast.Load())
-+
-+
- def _strxfrm(s):
- """Wrapper around locale.strxfrm that accepts unicode strings on Python 2.
-
-@@ -754,7 +766,7 @@ def parse_rule(self, node):
- if expr:
- tree.body = expr
- else:
-- tree.body = ast.Name('False', ast.Load())
-+ tree.body = _ast_const('False')
- ast.fix_missing_locations(tree)
- return Rule(type, tree)
-
-@@ -781,7 +793,7 @@ def parse_rule_node(self, node):
- expr = self.parse_bool_op(node, ast.Or())
- return ast.UnaryOp(ast.Not(), expr) if expr else None
- elif tag == 'All':
-- return ast.Name('True', ast.Load())
-+ return _ast_const('True')
- elif tag == 'Category':
- category = node.text
- return ast.Compare(
diff --git a/dev-python/pyxdg/pyxdg-0.26-r2.ebuild b/dev-python/pyxdg/pyxdg-0.26-r2.ebuild
deleted file mode 100644
index 0fb2dd272cca..000000000000
--- a/dev-python/pyxdg/pyxdg-0.26-r2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS="no"
-MY_P="${PN}-rel-${PV}"
-PYTHON_COMPAT=( python{3_7,3_8,3_9} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python module to deal with freedesktop.org specifications"
-HOMEPAGE="https://freedesktop.org/wiki/Software/pyxdg https://cgit.freedesktop.org/xdg/pyxdg/"
-SRC_URI="https://github.com/takluyver/${PN}/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( x11-themes/hicolor-icon-theme )"
-
-PATCHES=( "${FILESDIR}/${P}-python384.patch" )
-
-distutils_enable_tests nose